Ikea Tradfri Remote (5 button version) — was working, now doesn't, very confused

Continuing the discussion from IKEA TRADFRI Remote (5 button version) through ZHA events:

Okay, so… I have one of these devices from Ikea, and had it set up with the above automation to nicely control my Floalt panel. I then got two of the Tradfri outlets, and proceeded to set up one of them using a the two-button dimmer button. For the second, I tried to add it to ZHA using an ikea button (the just-one-button click one), but I couldn’t get it to pair, so I used to the 5-button remote. And it showed up fine that way, and I could then use an automation (specifically ZHA - IKEA Tradfri Shortcut button debounced) to make the button work to control it. (Weirdly, I can’t make an automation other than the blueprint with that button for some reason… it just doesn’t respond. But the blueprint works.)

But now… ooops. The 5-way remote is directly linked to that outlet. Not what I intended. Eventually, removed it, did the 4-click reset on the remote, and added it back again. It was discovered just fine… but now it doesn’t work. It shows up in ZHA like this:

… with “Desk Two?” being my attempt at getting it to work with the a new automation from IKEA TRADFRI Remote (5 button version) through ZHA events. The “Last Seen” time is just now, when I pressed the button. But the automation says “Never” under last-triggered, still.

What did I do wrong, and how can I fix it?

Hmmm. So, after doing nothing, I came back to this, and discovered it’s working. Is it just that these things take a while to “take”? How long is normal?

Is this something Zigbee2MQTT would do better?

You got me triggered with this:

How do you mean, you pair something with the use of a button. I know that pairing stuff to the IKEA bridge is basically a combination of a light/plug with a remote. But to pair them with ZHA, is just two separate devices.

Whenever I pair an IKEA <anything>, I reset it while ZHA is searching, and then it’s just there.

If you pair the remote to the light and the light to ZHA, the remote won’t show up in ZHA.

That is definitely not my experience! That would be nice, but I’ve had to go through this whole dance — the remote is used as a “steering” device" to cause the devices to pair.

What controller are you using?

The Nortek HUSBZB-1.

I mean, maybe I’m completely confused. Very possible!

Sorry, I’m new to HA and recently scored a bunch of the 5 button Tradri remotes while on a trip (we don’t have Ikea where I live). Are the Nortek controllers more reliable than Sonoff for use with Ikea devices?

edit: using ZHA for Zigbee integration currently as I haven’t yet dabbled with Z2M

I personally don’t have experience with any other controller, aside from the Conbee II that I use.

I’m pretty sure the controller doesn’t matter. It’s just plain worth the time to set up zigbee2mqtt.

I use a Conbee 2 (and ZHA) so this is not my findings (I don’t have this issue) however there is another thread on here with a lot of people reporting IKEA device extreme battery drain using the Sonoff controller.

And that’s also solved by switching to zigbee2mqtt.

Not according to the latest post.

Zigbee has poor range and penetration plus is sensitive to interference so regardless of Zigbee Coordinator adapter or Zigbee implementation it is recommended to optimize the whole setup for reliability to get the best possible range and reception with as little interference as possible. See tips:




Please consider giving that PR on GitHub a thumbs up if you think tips should be added to ZHA docs.