Incorporating new routers into existing Zibgee mesh network

Hello All,

I have a question regarding the pairing new end devices to zigbee rotuers.
I’ve heard when setting up zigbee mesh, you should start by pairing the routers to the coordinator first; then you can pair the end devices. This way the routers will also connect with the end devices.

So I already have a zigbee mesh network, so when I connect a new router (wall plug) it connects with the coordinator but not with the battery powered end devices. (I have seen this in the network map too)

The solution I thought was to start the mesh from beginning again (disconnect all the devices, pair all the rotuers first, then pair all the end devices) But then this isn’t exactly a solution, its too tedious.

Any thoughts… Cheers

Most devices will automatically chose and optimize the connection to the ZigBee mesh. So, if you setup a new router, both current routers and end-devices will over time move to this one, if better connection.

Some end-devices will not move, or will only move if they fully loos connection to the mesh, like the aqara sensors. Hence, if you implement a new router, which would be better for a end-device, you might need to pair them again. Even paired again might not solve it, then you have to only open this specific router for connection, choosing “pair through this device”. Possible in both ZHA and Z2M.

Yes, you’re right. I’m having trouble with aqara sensors. They don’t seem to connect through the routers.

I didn’t know about the ‘pair through this device’
How do I go about doing this with Z2M?

Thanks
Mari

Press the small down-arrow and those the device you which to go into pair mode
image

1 Like

I’ll try that.

Hi there,

Hope you’re doing well.
I tried connecting through the router and it now works perfectly! Thanks for that.

Now I’m encountering a rather funny situation. I have forgotten my home assistant URL. I changed it to my name but now when I try logging putting the URL in the address bar of chrome, I’m returned with an error.

Is there a way to reset this change? I think it may also be because I have connected a the Home assitat blue to a new router and its IP address has changed. But then I did try to sign into it by using the new ip address. “https://192.168.x.x:8123” But this hasn’t worked. Any help will be appreciated!

Thanks!

Not sure. You should be able to connect to the new IP address. The username/password on the HA should be the same as before.
Try without using “HTTPS”, try only with “HTTP”. The secure connection might stop working with a new IP address.
Otherwise open a new thread with a new and more correct subject line. People will not find this one as it is regarding Zigbee

Hi I’m using sonoff 3.0 zigbee stick and I was running mqtt on it it worked pretty well.
Until I changed the zigbee channel. Ever since then it has giving me an error.

I have reflashed the sonofff stick, I have uninstalled and reinstalled the zigbee2mqtt and mosquitto. I followed various different ways to set up mqtt in home assistant but none of them work for me anymore.

I have attached the log. Do you know what the problem may be?

image

No idea, have not seen this. I have changed the zigbee channel a long time ago, only thing to remember was to delet the config.backup file, as it will not change anything if this file is excisting.

If you do not care, maybe remove everything again and start over, however with a addition of deleting all the files in zigbee2mqtt directory. If you only uninstall, then it will not delete the configuration files. You can delete manually. The directory are in the config folder.

I deleted everything in ziggbee2mqtt .
Where is the config.backup file located?

And when you say delete everything and start fresh.
Do you mean delete remove all the devices?
How do I start everything fresh, I have tried everything and can’t pin point the fault.

If you deleted the "zigbee2mqtt directory, then everything related to zigbee2mqtt is removed, inclusive the config.backup. It should then be a fresh install of zigbee2mqtt.

If it failes again, please attach the configuration.yaml and the log file in the log directory of zigbee2mqtt.

Do you have any other mqtt devcices? If yes, are they working?

Yes I deleted the zigbee2mqtt directory several times and made a fresh start.

I’ll do it again from scratch and install zigbee2mqtt and mosquito again.

The mqtt devices are not working because the whole zigbee network is down. I can still turn them on manually, but I cant control them through home assistant.

I attached a the log of mqtt in my earlier message. There seems to be consistent error of zigbee herdsman not able to start.

I’ll attach the config file too when I’m home

OK, Got a little confused by you mentioning MQTT, as the problem is Zigbee2MQTT core according to the log above. The configuration.yaml and log.txt files might give a describtion of why it will not start.

Have it ever worked well?

Yes it used to work perfectly before.
I then changed the zigbee channel and ever since then it has not worked.
Then I unistalled zigbee2mqtt and mosuqitto and did a fresh install. Still didn’t fix anything.

Nothing else has changed.
I’ll send you the config and log.txt later today.

Thanks😊

Let me know if you spot any mistakes which is causing zigbee2mqtt to not start up.
The pictures on the top are from the config file directly and the bottom one is from the add on. (Not sure if they are any different)
The channel seems to be different, even though I changed both to be 15

05-12-2022 07_12_07-H__zigbee2mqtt_configuration.yaml - Notepad++

Have you looked at the suggested URL? Zigbee2MQTT fails to start | Zigbee2MQTT

Also, it might be worthwhile to increase the log level to “debug”.

Channel is set to 11 and 20. Not sure how you got them different. Try and set it to 15 in the add-on configuration, then delete the backup file “configuration.yaml.bk” in the zigbee2mqtt directory, Check the configuration.yaml file have the correct channel. Do a restart. Z2M will only do changes to the configuration if the .bk file is deleted.

If this makes Z2M working, however still having problem pairing devices again, change the PANID. When I changed my network key, I got some issues with re-pairing. This was solved by changing the PanID.

You serial port is directly to a USB port. This can give problems if the dongle is move between USB ports. Under hardware there is a option called “all hardware” (you need to press the 3 small dots in the upper right part). You should be able to find you direct port there. Mine is : port: >-
/dev/serial/by-id/usb-ITead_Sonoff_Zigbee_3.0_USB_Dongle_Plus_d617560171d9eb11bf30158e6fe9f4d9-if00-port0

Thanks dude!
I’ll try all these and report back.

The Pan id, an it be any 4 digit number?
And I’ll send you the direct port name, tell me if it looks correct. :slightly_smiling_face:

If I understand the z2m source code correctly, network_key should either be an array or a string saying GENERATE (to generate a new key). In your case it’s a string containing the key, which would seem invalid.

Try changing it to GENERATE to see if it will at least make z2m start up again:

network_key: GENERATE

Hi Robert,

I’ve changed the network key and pan id to generate but the z2m doesn’t wana start up.
Thats the config:

Thats the log:

Thats the config on home assistant: As you can see, the config on home assistant is not updating to the new one. Even after I deleted the entire aigbee2mqtt folder and installed z2m again.