Incorrect restored entity status

In my KNX network, I have an AC switch with address 0/3/47
When I use in the KNX YAML configuration file:


  • name: “B6 G - 1st - AC - Parents”
    address: “0/3/47”
    state_address: “7/3/47”

I get entity “restored” status and not functioning.

Any other address works like a charm.

Any idea?

Hi :wave:!
Any errors in the logs? See KNX - Home Assistant

Thanks for the prompt response.
Nothing in the log.

Maybe I can shed some more light.
This address was the first I tried when I integrated KNX.
I played with it, trying different types.
Then I added the rest of the addresses, had a duplicate, deleted it, and since then I cannot get it to work

BTW, when I change it in YAML to 3/0/147 (non existant address) it sends the telegram. Changing it back to 3/0/47, makes the entity red again.

If you change address: it will create a new entity. The old one will be orphaned and can be deleted. This address of a switch is a “significant address” and is used as part of unique id for the entity. See

I deleted the entity and tried again adding to YAML:

  - name: "Parents AC"
    address: "0/3/47"
    state_address: "7/3/47" 

reloaded and… nothing

Found it !!!

Entity was not enabled…