Home Assistant Community

Initiates (Probe) Outdoor Motion Detector

#1

Someone who knows why it is so, it never gets ready it says all time Initiates (Probe) and cannot be used.
This applies to an Everspring SP816 Outdoor Motion Detector that is included with Aeotec stick Gen5 EU, Rpi3 with HassIO HA HassOS 2.11, Home Assistant 0.91.3

0 Likes

#2

Do you have any way to wake up the device? it could be sleeping.
I am experimenting with a battery powered motion sensor. On mine, removing the cover triggers the “burgler alarm” and keeps it awake.

0 Likes

#3

Usually for battery operated devices the normal state is something other than “ready”.

You may be missing other entities that are correctly reporting the state change. Look for entities such as “burglar” or “alarm level” in your entities list. Or you may need to try to figure put how to change the report type.

0 Likes

#4

Te issue with my detector now is that I can see the “burglar alarm” but I cannot seem to see the motion switch changing.
This is a Ring motion sensor I added to OZW manually. I hope to contribute upstream after I get things working.

0 Likes

#5

Thanks,
how can i configure motion sensor1, that switch 2, ON when motion sensor1 detects the motion, and trigger a switch2 for 10 minutes, then OFF.
I’ve done this, in the automation.yaml, its correctly?

  • alias: Turn on kitchen light when there is movement
    trigger:
    platform: state
    entity_id: binary_sensor.everspring_sp816_outdoor_motion_detector_sensor
    to: ‘on’
    action:
    service: homeassistant.turn_on
    entity_id: switch.telldus_tzwp_100_plug_in_switch_switch_4
  • alias: Turn off kitchen light 10 minutes after last movement
    trigger:
    platform: state
    entity_id: binary_sensor.everspring_sp816_outdoor_motion_detector_sensor
    to: ‘off’
    for:
    minutes: 10
    action:
    service: homeassistant.turn_off
    entity_id: switch.telldus_tzwp_100_plug_in_switch_switch_4
  • alias: Message to pushbullet
    trigger:
    platform: state
    entity_id: binary_sensor.everspring_sp816_outdoor_motion_detector_sensor
    to: ‘on’
    action:
    service: notify.mypushbullet
    data:
    title: Motion
    message: Motion frontdoor
0 Likes

#6

at first glance it might be right but there is no way to know for sure unless you format you code correctly in your post

And I assume that means you figured out that your motion detector was really working after all?

0 Likes

#7

Excuse me.
this is from automation.yaml.
id numbers i think they are created by home assistant, may not know anything ,new i have missed.

- alias: Turn on front light when there is movement
  trigger:
    platform: state
    entity_id: binary_sensor.everspring_sp816_outdoor_motion_detector_sensor
    to: 'on'
  action:
    service: homeassistant.turn_on
    entity_id: switch.telldus_tzwp_100_plug_in_switch_switch_5
  id: 3379f5b6e13e479c999d9eddc0799754
- alias: Turn off front light 5 minutes after last movement
  trigger:
    platform: state
    entity_id: binary_sensor.everspring_sp816_outdoor_motion_detector_sensor
    to: 'off'
    for:
      minutes: 5
  action:
    service: homeassistant.turn_off
    entity_id: switch.telldus_tzwp_100_plug_in_switch_switch_5
  id: 860794af746f4b7ba398db69548fcf4e
- alias: Message to pushbullet
  trigger:
    platform: state
    entity_id: binary_sensor.everspring_sp816_outdoor_motion_detector_sensor
    to: 'on'
  action:
    service: notify.mypushbullet
    data:
      title: Motion
      message: Motion Garage
  id: 19fdc20f080949559786980506f75c62
0 Likes

#8

Everything you have there should work assuming all of your entity_ids are correct.

The only thing to point out is that you don’t need to use homeassistant.turn_on/off for your action service. you probably should use switch.turn_on/off but it will work either way in this case.

Have you actually tried to test it yet?

0 Likes

#9

I have tested with aeotec sensor and Telldus switch and have worked well so far.
Has tested with Everspring SP816 Outdoor Motion Detector but it does not always work. Should try with what you said with switch.turn_on / off.
The only thing I am not sure is that the motion sensor is not ready when I check

0 Likes

#10

If it works once then that tells you that the code is correct.

Not sure what you mean by “the motion sensor is not ready when I check”?

0 Likes

#11

I mean this, EverspringSP816 multi sensor (initerar Probe). Perhaps that is because it is battery driven as you said but it is not wrong with it.
But thanks for the help.

0 Likes

#12

I can manage to get motion sensor EverspringSP816 to trigger the switch .
Have you any suggestions, can you help me with that.
in OZW Log I do not see any problem.

0 Likes

#13

what are all of the entity_ids associated with that device?

if you go to the states page and in the filter put in “everspringsp816” then take a screen shot of all the entities that show up in the list.

1 Like

#14

In the states page filter “everspringp816”

0 Likes

#15

there should be several other entities associated with that same device such as sensors and hopefully even a binary sensor.

they should look like:

“sensor.everspring_sp816_outdoor_motion_detector_alarm_level”
“sensor.everspring_sp816_outdoor_motion_detector_alarm_type”
“sensor.everspring_sp816_outdoor_motion_detector_burglar”
“binary_sensor.everspring_sp816_outdoor_motion_detector_sensor”
etc.

EDIT:

What device is node 21?

0 Likes

#16

EverspringSP816 multi sensor

The only one that couldn’t get started is everspring SP816.
there was no problem with the Aeotec sensor, but I want a sensor out.

0 Likes

#17

That’s strange then since in your screenshot before this it shows “node_id: 19” and the log you showed had a bunch of “node021” entries but you are saying those are the same device…?

Anyway looking at your screen above I see a “Everspring SP816 Outdoor Motion Detector Sensor”.

I’m pretty sure that is your binary sensor you need to be looking at. The entity_id should be “binary_sensor.everspring_sp816_outdoor_motion_detector_sensor” or something. See if that exists in your states page. You don’t show it in your list of entities above but it almost certainly exists.

Then check to see if it turns on and off when you flag the detector.

Then if that doesn’t work check the “sensor.everspring_sp816_outdoor_motion_detector_sensor_alarm_level” to see if it goes from 0 to 255 when you trigger the motion detector then back to 0 when the motion detector resets.

0 Likes

#18

When I trigger sensor, detector burglar changes to 8

0 Likes

#19

what about the binary_sensor I asked about above? does it change also?

0 Likes

#20

I changed in automation.yaml with sensor.everspring_sp816_outdoor_motion_detector_burglar,
but sensor does not trigger the switch i have in automation.yaml,

switch.telldus_tzwp_100_plug_in_switch_switch_5

0 Likes