Input_datetime fails on simple UI change

Maybe this is something simple but I can’t find the answer. I have an input datetime showing on an entity card but when I try and change it I get an error message as shown in the pic below. yaml for the card:

      - type: entities
        show_header_toggle: false
          - entity: input_datetime.hannah_alarm_time
          - entity: automation.hannah_alarm_clock

I use yaml for my config so the intialisation of the helper is:

    name: Hannah Alarm Time
    has_date: false
    has_time: true

the date time is not used anywhere except in one automation which triggers at the time. excerpt:

  - id: Hannah_alarm_clock
    alias: Hannah Alarm Clock
      platform: time
      at: input_datetime.hannah_alarm_time

Any ideas?

I see nothing wrong here. Perhaps it’s a mismatch with your locale settings? For example, your input is 12-hour time, but your locale uses a 24-hour format.

This is in the user settings

I’m guessing a bit here…

What happens if you try to call the set service under the dev tools? Do you get the same error?

How do you sync your config to your server? If you do this, check the file(s) on the server to make sure it contains the expected config. Do a restart for good measure. Do you typically restart after making changes or do you do a reload of config?

This really shouldn’t be the case, but if none of the above makes a difference, remove the line with has_date: false, sync and reload/restart.

No I think that worked fine. However, when I navigated to the dashboard which shows that datetime the error straight away showed at the bottom but the value was as set back on the dev tools?

I don’t think it should make any difference but this dashboard is a sub view…just trying to think what might be non standard. Tomorrow I will try putting the date time on a different view and see what happens.

Oh and I just edit my yaml directly on the server via a samba share. I do a reload if it is an option otherwise restart.

Edit: Just updated the OS so a full host restart but still same behaviour

clear your cache and refresh the page

1 Like

No change. Tried in a incongnito window as well?

Tried a non-sub view and same thing

Let us know when you’ve tried this.

Another thing: Which custom frontend components do you have installed? Perhaps start commenting out the loading of such resources one by one under the resources section in your configuration.yaml.

Yes done. Thats what I meant about a non-sub view. I just put it on my regular test view and same problem

Quite a few

  mode: yaml
  # Include external resources only add when mode is yaml, otherwise manage in the resources in the lovelace configuration panel.
  - type: module
    url: /hacsfiles/ha-floorplan/floorplan.js
  - type: module  
    url: /hacsfiles/bom-weather-card/bom-weather-card.js
  - type: module
    url: /hacsfiles/mini-graph-card/mini-graph-card-bundle.js
  - type: module
    url: /hacsfiles/lovelace-slider-entity-row/slider-entity-row.js
  - type: module
    url: /hacsfiles/bar-card/bar-card.js
  - type: module
    url: /hacsfiles/lovelace-valetudo-map-card/valetudo-map-card.js
  - type: module
    url: /hacsfiles/button-card/button-card.js
  - type: module
    url: /hacsfiles/vertical-stack-in-card/vertical-stack-in-card.js
  - type: js 
    url: /hacsfiles/lovelace-card-templater/lovelace-card-templater.js?v=0.0.2
  - type: module
    url: /hacsfiles/lovelace-card-tools/card-tools.js
  - type: module
    url: /hacsfiles/apexcharts-card/apexcharts-card.js?v=1.10.0
  - type: module
    url: /hacsfiles/mini-media-player/mini-media-player-bundle.js?v=1.16.2

Unfortunately no good. I commented everything but floorplan and still same problem

And did you do a hard refresh to make sure nothing’s cached? You can also open your browser’s dev tools and disable the cache completely.

The next step, I think, would be to rename your custom_components directory too just to be completely sure none of that code is being loaded — and do include the floorplan card too. I’ve seen it spew lots of JS errors.

when you look at the entity in the state tab of developer tools, is there a editable tag?

im just wondering is something was changed and not documented

actually i seem to remember something with milliseconds… i had issues a long time ago when something changed…

also what if you disable the automation? to confirm its just the card service call

Actually editable is false :flushed: WTF that isn’t mentioned in the docs

Edit: just tried to add an editable key and that failed… Open to ideas!

It might mean it’s editable as an input helper, not the value… I’m not 100% on what it’s for

I did read somewhere that datetime only has hh:mm and time has hh:mm:ss but I can’t find anything about it now.

Can you just create a new datetime with a helper?

OK I created the datetime via the UI.Same problem. I don’t use the defailt config could there be some dependency issue?

so just creating the helper, and adding it to a entities card doesnt work? on mine it does…

did the editable attribute change when you created via the helper ui?

i have no idea why it wouldnt work, im just spitballing ideas


I know… this is painful and will be more so if it turns out to be something obvious…

This is bizarre…

New theory:

Did you perhaps create that helper the first time when you were in UI mode for editing dashboards and then switched to YAML mode?

If you could, can you find all the references to this helper in the .storage JSON files?

Similar post, also unsolved, but the source of the above:

No I generally don’t use UI mode. The first time I ever created anything other than one dashboard was today doing testing with this. OK will delete the helper from the UI then see if it still exists in the .storage folder. Also that does look like a similar problem.