Install HA on PI 4 - SSD - Nothing happens

I have updated firmware on a RPI 4 and added HA on the SSD. When I plug in the power nothing happens?

  1. Updated firmware (confirmed that it boots from ssd / usb when addin Raspberry Pi OS on the ssd , it works)
  2. Downloaded HA, extract it and use etcher to flash to the SSD
  3. Putting Rpi with network cable (that works) and plugged in the cable.
  4. Waited for 4 hours, nothing happens.
  5. RPi not on the network

What do I do wrong?

When using usb 2.0 port it worked :confused:

I had the same problem until I found this link installed Build 5.1 then the PI boots from SSD in USB3.

Just a update!! This is buggy I have no understanding why but HA kept loosing my MQTT switch and light states so I went back to my old constantly updated All In One Installation which is working great. Sorry if I mislead anyone!!

You need a RPI4 with newest firmware and home assistant OS 5.x this works reliably with usb3.0
See my post here

Thank You for your reply. Just to clarify I am not having issues with booting from a USB 3 port on my Raspberry PI 4 with the HASSIO OS install. I believe the problem I am having is moving my current *.YAML configuration files from my old original All-In-One-Installation to HASSIO. I have continually done upgrades and additions to my original install and that seems to be the main issue with moving to HASSIO. Thanks for sharing your knowledge I will keep trying to move to the latest releases in anticipation of the upcoming deprecation of the Home Assistant Core Method.

Core is not being Deprecated. You are incorrect.

Hass.io was renamed some time ago, please try to use the correct names. See here.

This post was flagged by the community and is temporarily hidden.

How lovely of you, thanks for sharing.

You have tried to use a Dev build and found it buggy, then blamed your config, used an incorrect name for a HA installation method, then made an incorrect statement about an installation method being deprecated.

Perhaps providing accurate information, error logs and the yaml configuration you believe is causing the issue would be helpful, that way, someone may be able to assist you.

/arrogant jerk

4 Likes

Sorry about the Jerk statement that was wrong, but felt a bit put off by your correction of my HASSiO correction to Hass.io, sorry I missed the period also I never said the installation method would be depreciated, I said it was MY ANTISCIPATION of the upcoming depreciation !! I will try to move my All in one installation to HASS.IO sometime in the future when I have several days to look through all the errors I have made in my CONFIGURATION.YAML files since I did my initial All In One Install which has been depreciated. Hopefully I did not offend you with my reply.

Not a worry, I found it amusing more than anything.

I wasn’t correcting the lack of a period, I was letting you know that that name is no longer used to describe an installation method. That name was changed some time ago.

I provided a link to another post that describes the current installation methods. Here it is again, check it out to help you understand which method might be best moving forward.

1 Like

OK looks like we are back on a civil communication level, sorry I miss understood, that seems to be all of us in the US are having a issue with civility!! Back to one of my issues moving to to hass.io on my current system is my Raspberry PI system with a camera which worked with my current working system but when I tried to make it work with the hass.io install I could not find a way to make it work. Any Ideas? Thanks again, also sorry about the arrogant word?

If you need an underlying OS like Raspberry Pi OS to enable and manage a Pi Camera attached to the board via ribbon cable (I’m assuming that’s what you mean), then you would need to use HA Core, but you will not get the Supervisor.

If you want/need the Supervisor, then a Supervised install will work so you can use the Raspberry Pi OS to install the packages you need. Keep in mind that doing so will make the install unsupported.

You may be able to enable and use a Pi camera with the standard Home Assistant OS image available here, but I have no experience with trying to do that so can not comment on if it will work.

I have 2 guides in the Community Guides section that go through installation of HA Supervised on a Pi running Raspberry Pi OS and Debian 10. Perhaps one of those will help you.