Installation failing in raspberrypi3


#1

Hi, I am installing homeassistant in my raspberry pi 3, and it is failing. Can someone help me?

(homeassistant) [email protected]:/srv/homeassistant $ python3 -m pip install homeassistant
Collecting homeassistant
Could not find a version that satisfies the requirement homeassistant (from versions: )
No matching distribution found for homeassistant
(homeassistant) [email protected]:/srv/homeassistant $

I followed this instruction:https://www.home-assistant.io/docs/installation/raspberry-pi/


#2

Just curious. Any reason you are not using a docker based environment such as hassio?

I just manually installed hassio on raspian lite this weekend. Hassio provides many addon tools as docker containers.


#3

I didnt know you can install hassio on raspbian strech lite. is there any how to guide?


#4

Not really. Here’s what I did:
NOOBS Lite -> Raspian Lite

I followed the instructions to install Hassio for Linux with a couple of changes.

There is no Universe repository, so that was ignored.

We need to specify the architecture in the command to install Hassio.

As root,

curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install" | bash -s -- -m raspberrypi3

#5

What I did this (before moving to a NUC) I used Dale3h’s script from here https://github.com/dale3h/hassio-installer
(I used a Pi3b not a 3B plus and it worked fine)


#6

That looks great. Is there a similar guide for a zero w, or will that suffice?


#7

Hi all,
can anyone guide me in the direction to install hassio on RPi 3B+ with pivpn installed?


#8

You’d have to install Raspbian, with PiVPN, then perform an alternate install manually.


#9

Installed recently on a Raspberry Pi 3 running Raspbian Stretch Lite using the instructions you linked with no problems.

Are you sure you are following the instructions exactly as they are laid out step by step.


#10

Following this instructions it works a little.
But it lacks the hass.io in the panel.


#11

I’m on the full stretch version.
After following script from Dale3h n the post here (with docker) it comes up with an error when creating account.
"failed to fetch up“


#12

The RPi had 2 IP’s.
One for the wired and one for the wireless.
After the docker script the IP changed and is not accessible.


#13

Check that your configuration has hassio: in it, as explained here.


#14

Stretch Lite is the way foreward. Ensure you have the blank ssh file and the wpa_supplicant.conf file with your WiFi credentials in the /boot folder before you proceed with the Hass installation if you’re going the wireless route.

That link you posted originally works perfectly for Hass installation in the venv


#15

Tried so many things now, I’m not sure anymore wich instruction works and wich not.
One is complaining about arm.
Other seems to work but messed up the name and IP-address resulting in multiple IP’s.
If I cannot find a way to delete last created IP and disable wifi I will do a clean install of rpi + pivpn and forget home-assistant.


#16

Just start with a freshly formatted SD card. Download and write a Raspbian Stretch Lite image to your card. Prefigure your SD card for ssh and WiFi as I pointed out above and do the usual update/upgrade.

Once completed follow these instructions exactly as they are laid out. I tried this an hour ago and it works https://www.home-assistant.io/docs/installation/raspberry-pi/


#17

This way was my first attempt.
Fresh Stretch Full img boot from ssd.
Skipped the preparations for wifi and ssh.
Installed PiVPN.
On the RPi desktop I followed the instructions you link to.
It worked indeed (127.0.0.1:8123).
But there was no hassio in the panel on the left side.
Besides I did not manage to get it started as daemon (in next part of your link) my IP and name changed when I activated the Virtual Environment and the prompt changed.


#18

See what I can do with /etc/dhcpcd.conf to get it back the way it was.


#19

The install instructions call for Raspbian Lite. Please use Lite not Desktop (Full)


#20

You only get the Hass.io menu if you used the Hass.io installer. If you followed the Raspberry Pi guide you installed Home Assistant.