Installation guide for Raspbian?

I have a headless RPi3 model B with a fresh install of

I followed the instructions at “ on generic Linux server”

There’s a problem using them on Raspbian: the hassio_install script needs to be downloaded and run with a “-m armv7l” parameter, or it fails with:
[ERROR] Please set machine for armv7l

With that change, it ran without reporting any problems:
r oot@homeypi:~# chmod +x hassio_install
root@homeypi:~# ./hassio_install -m armv7l
[Info] Install supervisor Docker container
[Info] Install supervisor startup scripts
Created symlink /etc/systemd/system/ → /etc/systemd/system/hassio-supervisor.service.
[Info] Install AppArmor scripts
Created symlink /etc/systemd/system/ → /etc/systemd/system/hassio-apparmor.service.
[Info] Run

hassio appears to have been installed and started successfully:
root@homeypi:~# ps aux|grep hass
root 5360 0.0 0.1 1900 1112 ? Ss 10:17 0:00 /bin/sh /usr/sbin/hassio-supervisor
root 5404 0.0 3.7 913508 35892 ? Sl 10:17 0:00 docker run --name hassio_supervisor --security-opt apparmor:unconfined --security-opt seccomp=unconfined -v /var/run/docker.sock:/var/run/docker.sock -v /var/run/dbus:/var/run/dbus -v /usr/share/hassio:/data -e SUPERVISOR_SHARE=/usr/share/hassio -e SUPERVISOR_NAME=hassio_supervisor -e HOMEASSISTANT_REPOSITORY=homeassistant/armv7l-homeassistant homeassistant/armhf-hassio-supervisor
root 5459 0.7 3.2 54048 30768 ? Ssl 10:17 0:03 python3 -m hassio

But there’s no docker container for homeassistant, and nothing is listening on port 8123. The /usr/share/hassio/homeassistant directory is empty. There is no configuration.yaml file anywhere in the system.

Is there some other installation step I’m supposed to follow? And will the web interface be available from elsewhere on the LAN? There’s a cryptic comment that " the core SSH add-on may not function correctly", and references to accessing the web interface via “hassio.local”, suggesting that the docker containers aren’t on the internet.

It needs to download the image for home assistant so if your internet is slow, you have to wait. There are times it takes my internet nearly an hour to download the home assistant image.



Not cryptic at all. There is an SSH add-on. It won’t work if your host is already listening on port 22 for SSH.


The system will broadcast via mdns or bonjour that it’s name is hassio.local. That has nothing to do with being on the internet. It’s a local address accessible on the same LAN.

Thanks for the quick reply.

It’s definitely not download speed: my Internet connection typically runs between 5 and 10 megabits/sec, and I left the Pi running overnight (over 7 hours) without it doing anything visible toward installing anything else.

And thanks for mentioning mdns: I haven’t paid much attention to it. I’ve been doing networked SBCs and other gadgets for years, and developed habits of making sure everything had hard-coded static IPAs or DHCP reservations. It looks interesting, but I have a bunch of stuff installed that doesn’t support it. Since I didn’t know about it, I mistakenly assumed that the “hassio.local” meant something similar to “localhost”.

I tried doing a pip install of homeassitant, but that didn’t set up the docker container. I may have to go back to the old-fashioned method of running it.

Thankjs again,


That’s not fast internet. :smile:
I know because mine is 5mbps and it’s freaking slow.

If you left it overnight then something else is wrong. Look at journalctl -xe, look at the services, and check docker ps -a.

Yeah. Pip is Python and has nothing to do with docker. That’s basically installing home assistant on the host without docker at all. It’s also not going to run hassio that way.

I think I still have the Hayes 300 baud modem I used to log on to CompuServe almost 40 years ago in a box of “souvenirs” in the shed.

There don’t seem to be any internals docs that would help me figure out what went wrong, and I’m not up for reverse-engineering the system architecture, so I’m just going to drop this and look into other options.

Thanks again,


I don’t see how basic troubleshooting is “reverse engineering” anything.

Well alright. See ya.