Installation Home Assistant on debian 11 on my rock4C+

Hi all,

I have started my first project with a Radxa rock 4C+
After the installation of debian 11 via sd-card, i wanted to install home assistant.
I therefore used the information from: Install Home Assistant on Debian Linux

Guidance from this tutorial was good.
Installation of docker was succesful.
But the available OS-agents from github (Releases · home-assistant/os-agent · GitHub) were not working for me.
I tried a couple of them, but they all gave me the same feedback (see picture: package architecture does not match system.

Is there a way forward for my setup when i want to install home assistant?
I din’t find a full answer for my problem on the forums i looked at.

Many thanks!

Kind regards,

Supervised is a trap, and following some third party guide is just going to cause problems.

The Supervised installer comes with many warnings for a reason. Many people writing their own guides skip over those, and the requirements, because they don’t think it matters.

If your device doesn’t support Home Assistant OS then the only sensible choice is native Docker - no supervisor, no add-ons.

1 Like

4 posts were split to a new topic: Supervised on VMware v6.7.0 U3

Thanks for the feedback @Tinkerer !
I tried the link, but got stuck on the “libseccomp” requirement (how to get these?) and the script (which folder to choose for the confif files?).

Can you or anybody else help me out with this?

Thank you,

If you’re using Debian 11 (Bullseye) then libseccomp2 is what you’re after

As for the folder, that’s personal preference.

I like to use /data for all my data, and then folders for everything:

/data/docker        # Docker compose file and related files
/data/homeassistant # Home Assistant config folder
/data/zigbee2mqtt   # Zigbee2MQTT config folder

Now I can back up /data and get everything.