Installation obstacles

I have three obstacles when trying to install and configure Hassio.

  1. I am able to connect to my Android phone via wifi but it will not install Home Assistant. It just sits there for hours. I’m only able to connect using the IP Address and not through hassio.local:8123.

  2. I’m unable to connect it through my home wifi. I have a Netgear xxxx router. I tried formatting the SD card and place 32bit and 64bit OS a few different times. I tried a few different usb setups after the main instructions on the Home Assistant Installing page didn’t work. (I think maybe I have to reset something? But I don’t know)

  3. I was able to connect using Ethernet cable (only using IP address and not hassio.local:8123) and I was able to install add-on’s. Addons I installed are DuckDNS, Configurator, SSH Server, Samba etc. The problem was that I couldn’t connect to the confuguration yaml file using Samba or the Configurator addons. It came up blank and it wasn’t on the pull down list. (I wounder if connecting to my Android phone first, missed things up)

Any ideas???

Thank you for any help you can provide

hassio.local won’t work on a lot of home networks, I don’t know why the instructions suggest that it will. This is not an issue, just use the ip address.

I don’t understand this bit, can you explain a bit further what you tried and what results you got? If you were able to install addons it’s fair to say that your configuration.yaml is there and correctly implemented, but obviously you’re going to need to edit it and it should be as easy as bringing it up on a Samba share.

It should be. A lot of people seem to be having trouble though:

1 Like

Oh dear, another reason to steer clear of hassio.

Always the problem when complicated things are made to be ‘easy to use’. When they don’t work its a nightmare :see_no_evil:

Having said that a lot of people (me included) have absolutely no issue with the SAMBA add-on. There’s a reason these people have issues, we just haven’t worked out what it is yet.

After I installed the Configurator addon, I edited the config file in the addon to add a user name and password and saved it. When I opened Web UI and logged in, instead of getting the configuration.yaml file, it opened without any file selected. meaning, there was no header and the body was blank.

Clicking on the fold icon on the top left side, there was no configuration.yaml file in the drop down list or any other yaml file for that matter.

I’m at a loss. I’ve been working on the for two weeks now.

Thank you for your response mf_social. I appreciate it greatly

By the way, I took those samples from youtube

Try clearing your browser cache and reloading the page?

When I get home later, I’ll try that.

Is any aspect of the installation saved on the Home Assistant web site?

The reason I ask, is because I would like to start over from scratch and make sure every thing is cleaned up before I start again.

Thanks again

No it’s completely local, so if you flatten your installation and start again from scratch you’ll get a brand new one.

Continuing the discussion from Installation obstacles:

I got it to work this time. I think clearing my browser cache helped. I’m bummed I can’t connect through my wifi though. It never shows up on my router connections. Also, the only way it would connect is by using the IP address and not through http://hassio.local:8123. The weird thing is, I can connect it to the wifi from my tethered phone. But It never went further than the Preparing page when connected to my phone.

The good thing is, I got it working through the Ethernet connection and I will worry about wifi later.

Thanks for all the help

Stay on ethernet connection, much more stable.