Installation of deCONZ REST API with + ConBee


I am running (HassOS 2.8) with a Raspberry 3 b+ and a ConBee USB Stick by dresden elektronik for providing a Zigbee Router. I have installed the official deCONZ plugin through the hassio addon-store.

The setup works so far with IKEA Lamps. However, I want to add to deCONZ a Zigbee Heiman Plug which apparently is not supported by the user-friendly Phoscon app. So, I think I would need to add the Zigbee Plug manually by using deCONZ REST API (

It seems to me that deCONZ REST API plugin was not installed by the official deCONZ hassio addon. Because when I send a GET request to (as it is instructed here I do not get either IP-Adress or PORT of any REST gateway.

So, could anyone help me with the installation process of the deCONZ REST API plugin to Hassio? I am not very familar with installing plugins in Linux using ssh.

Thanks in advance!

Worked it out. No installation of REST API needed. The get discover command didn’t work as the respective port 8080 was not forwarded from my router to my RaspberryPi.

After I l forwarded the port the discover command found my gateway. However, the command gave me an output of strange ip addresses so it was of no help.

The following way to connect to REST API worked for me:

In HomeAssistant, go to your Dashboard an click on the deconz addon. Scroll down to the network part. The host of container 80/tcp is the right port to connect to REST API. In my case it was port 9880.

So, the REST API can be adressed by network ip of you RaspberryPi and the respective port, for instance:


Hey @zubredo, sorry for waking up the dead :sweat_smile: But I wanted to thank you for your help!
It did not work for me but brought me to the right solution. Just in case anybody has the same issues as me:

When I run the curl -X GET -k -i '' I got the the following result:


But I could not access the IP and port, I needed to ssh into my hassio system. Look here!
After that, I needed to unlock the Gateway under the deconz Web UI > Setting > Gateway > Advanced > Connect App and then I could finally access the REST API from deconz with:
curl -X POST -i 'http://<IP>:<PORT>/api' --data '{"devicetype": "my application"}'

Also thank you for the help. I still had some difficulties to connect to the API because of the latest update. I like to share them to save some time

Steps I took:
1 Go the the Deconz ad on
2 Go to Configuration
3 Net
4 where it says 40850/tcp ‘disabled’ change ‘disabled’ to ‘40850’.
5 open the phoncon app
6 go to Gateway -> Advanced and click on ‘Authenticate app’
7 Fire the API with a Rest client