Installation of Hassio on Synology NAS

Hey Guys… So I installed home asistant on a VM and started up fine and added a nest smoke alarm for testing… looks good

Then I wanted to install it on my DS918+ which has docker capabilities… When I did that I saw that the plugin page was missing… Then I tried the 2nd install method to directly run on DSM via https://home-assistant.io/docs/installation/synology/

But that had some startup problems (GUI came but complained about missing some python binaries) and then again the plugin page was missing…

My basic use is going to be that I want to use google assistant to control devices and have homekit support so install the homebridge plugin.

I ideally also want to run it on the NAS somehow with full capabilities so that I don’t have to buy another device (i.e. Pi) or run it in a VM on a computer…

Anyone had any experience with this and suggestions?

Also where people mention hass.io it means a Pi install? v/s Home Assistant means a custom install? Bit confused between what the community terms are…

1 Like

I helped someone install on Synology. I thought it was going to be easy. Basically you install a 3rd party Debian chroot package and instal hass into that. Not as easy as I expected.

You installed wrong docker package

You need home-assistant/hassio:latest or similar to get plugins

Docker on Synology like point you to home-assistant/homeassistant:latest

Not sure how you get that installed but that will give you what you want. When I use Synology I install and using command line via ssh. It was much easier.

What? lol… thanks for that… home-assistant/hassio doesn’t show in docker registry in DSM. Do you have some guide on how to do so so that it plays nicely with DSM? (like username / folders / docker image etc shows on DSM)… I am guessing

$ docker run -d --name=“home-assistant” -v /path/to/your/config:/config -v /etc/localtime:/etc/localtime:ro --net=host homeassistant/home-assistant

And that will show in DSM docker? the above command might not be the one for my scenario? might have to do some docker pull or something?

No guide

Your docker run command will work fine. Just point to the hassio docker image and it will be downloaded…just FYI…dsm will retrieve anything available from dockerhub and standard docker commands work from command line. This is why I prefer command line on Synology for docker container Creation, the GUI was incomplete

Synology units that don’t support docker must have some Synology specific python package installed to run docker

sudo docker run -d --name=“home-assistant” -v /path/to/your/config:/config -v /etc/localtime:/etc/localtime:ro -p 8123:8123 homeassistant/resinos-hassio:

https://hub.docker.com/r/homeassistant/resinos-hassio/

I don’t like net=host because I dont want more connections then needed

I specify version so home-assistant/hassio:0.69.1 for example

I get this when running as root

ash-4.3# docker run -d --name=“home-assistant” -v /volume1/homeassistant/:/config -v /etc/localtime:/etc/localtime:ro -p 8123:8123 homeassistant/resinos-hassio:0.69.1
Unable to find image ‘homeassistant/resinos-hassio:0.69.1’ locally
docker: Error response from daemon: manifest for homeassistant/resinos-hassio:0.69.1 not found.

ash-4.3# docker run -d --name=“home-assistant” -v /volume1/homeassistant/:/config -v /etc/localtime:/etc/localtime:ro -p 8123:8123 homeassistant/resinos-hassio
Unable to find image ‘homeassistant/resinos-hassio:latest’ locally
docker: Error response from daemon: manifest for homeassistant/resinos-hassio:latest not found.

I am guessing I have to choose nuc or pi1/2/3 as listed here https://hub.docker.com/r/homeassistant/resinos-hassio/tags/ ??

Have you used the pull command to download the docker image? e.g.

docker pull homeassistant/home-assistant

Then use your docker run command

Yes. Couldn’t find proper tags to recommend.

homeassistant/resinos-hassio:1.1-intel-nuc
Raspberry pi version may work also.

This is 4month old. Not sure what version Hass.
Please let us know if it work

I have this locally

ash-4.3# docker pull homeassistant/resinos-hassio:1.1-intel-nuc
1.1-intel-nuc: Pulling from homeassistant/resinos-hassio
Digest: sha256:e468f80c33b588ceb3d2efdb748e95e49da88c3a4c10c65fa0cd8d16373ba656
Status: Image is up to date for homeassistant/resinos-hassio:1.1-intel-nuc

ash-4.3# docker run -d --name=“home-assistant” -v /volume1/homeassistant/:/config -v /etc/localtime:/etc/localtime:ro -p 8123:8123 homeassistant/resinos-hassio:1.1-intel-nuc
docker: Error response from daemon: No command specified.

not sure but no matter.the image should now be accessible in DSM so you may create container through gui

Yes… I tried that as well… it is basically missing the execution command…

I copied the one which is created by homeassistant/home-assistant (python -m homeassistant -config /config) but that didn’t work either… and gave it all the Path variables which is created by the above mentioned image as well…

Still I get an error “container undefined does not exist”

I had read that… my NAS is x86_64

But I think that is suggesting to use the hassio_install script? I had tried that but then I am missing socat and other packages… so I believe i will have to skip docker and then install all the dependencies manually before running the script?

I have even tried hassio_install script… but after much changes to script… it still fails as “systemctl” is not found on NAS.

i dont use hass.io except on some RasPi.
honestly i think running standard homeassistant will do fine for you. I beileve biggest benefit of hass.io was update software and docker takes care of that issue. the other items provided through plugins are easily implemented or where separate containers on OS anyway which are easily installed in docker.

Ok… So I am a bit confused now… So I should install homeassistant/home-assistant:latest ?

I understand that components are available for any install. The main plugin I require is homebridge for ios compatibility…

Which means I install some homebridge docker which will interact with the homeassistant docker?

hey @its

I think I’ve done what you’re trying to do. See https://philhawthorne.com/installing-home-assistant-io-on-a-synology-diskstation-nas/

That should get you up-and-running.

Thanks… home-assistant is running fine via default docker image… I am trying to install hass.io which has the plugins (hass.io on the left hand side menu) page etc to easily install addons like homebridge etc… within homeassistant

1 Like

Ah right. Yeah I’m struggling to get HASS IO on the Synology atm :frowning:

Hassio is in its base nothing but:
hassio-supervisor docker
homeassistant docker
hostcontrol

You do not actually need the hostcontrol, it only does things like reboot/shutdown of the host.

Check this repo: https://github.com/home-assistant/hassio-build/tree/master/install#install-hassio

Read the install script: https://github.com/home-assistant/hassio-build/blob/master/install/hassio_install

It does some requirement checks, builds strings appropriate for your architechture and then install a couple of services. Those services start the supervisor docker and the hostcontrol, you only need the supervisor.
So if you can create a script which does the same as the hassio-start script here: https://github.com/home-assistant/hassio-build/blob/master/install/service/hassio-start
You are good to go.

I have managed to run hassio on my Asustor NAS this way.