Installation on Synology Virtual Machine Managager

You can setup subdomain for home assistant and obtain separate certificate from Let’s Encrypt.
Use Proxy in Synology - create subdomain (say, home.yourname.synology.me), enter local IP and port of your HA, obtain a new certificate and you’re done.
I have some sort of guide HERE, but it’s only for guidance, you replace all needed data with your data from HA. And there’s an error: only one port forwarding is needed in router: 443. Second one is not needed.

Thanks. I have done this:

On my router I have added a port forward for port 443 to 443 to my Synology IP.

I have created a Reverse Proxy on Synology for hostname ha.name.synology.me. I have also added a certificate for this hostname. On reverse proxy settings I have added the ha hostname as source, HTTPS and 443 and destination the HTTP internal IP of my HA with port 8123. Created Websocket also.

If I visit https://ha.name.synology.me, I get 400: Bad Request. What have I done wrong? :slight_smile:

Hm…
I think that port forwarding from 443 to 443 could/may be wrong, since you probably don’t have your Synology https set to 443 (default is 5001 or something…). I have port forwarding entered like this: external port=443, internal port=left blank, IP = local SYNO port. I believe that it will also work if you enter 5001 as internal port (or whatever https port you have set in Synology).

Can you access your synology server from outside world? Typing: https://yourname.synology.me should get you to login portal of your NAS.

Do you access your HA locally via http or https? If you set it up to access via https then remove that setup. Your local access address should be http://192.168.x.yyyy:8123 (not https!). I remember that i’ve had problems when i’ve had setup to access HA loccally via https…

EDIT: also try to delete browser cookies.

I can access Synology via yourname.synology.me outside the network without any port forwarding rules. If I remove the internal port, the new ha.yourname.synology.me host redirects me to Synology login and not to Home Assistant. I can also access HA locally with no problem on HTTP. I just dont get the hostname for synology & HA to work.

I have also set a port forwarding rule on router to forward 8123 to 8123 HA internal IP and it works fine… But on http of course, not on https.

That’s strange…But, i guess that if ha.yourname.synology.me takes you to NAS main site instead to HA it’s something wrong in proxy settings in Synology, because subdomain (prefix home, ha…) is managed by Synology proxy and not by your router. Sadly here my knowledge ends…i hope someone else will be able to help you.

I attached pic of my settings, just in case for you to compare settings. Note that i have DSM7.0, so look can be somewhat different, but settings are the same.

See this post for a solution that worked for me

trying out HASS in VM on Synology for the first time…all installed fine but wondering why I don’t see Supervisor in side bar, even though it states it is running fine in the system tab

looks to be enabled here as well

thanks in advance and sorry if a stupid question

Did you enable advanced mode in settings?

yes i have (hadn’t originally but found that needed doing a bit later on) have done so and restarted both HASS and the VM itself…but still not showing

FYI, I install the alternative ova as per the screenshot

Im coming from Docker install in case I seem a little green

Have a look at the latest release notes: supervisor is no integrated into the settings.

2 Likes

superstar…thanks…thought Iw as going mad

Hi, I have a problem installing home assistant on synology Nas. I have done an installation of the same type previously on an identical Nas and have not had any problems. Basically when I try the virtual machine manager wizard I get the error “cluster creation failed”. You can help me?

Cluster cretion? Do you have 2 or more NAS devices in Cluster or are you trying to create cluster? You shouldn’t get this error when creating just VM.

Hi Guys,

I’m stuck during the installation on my new DS920+, i have installed everything following the instructions here above and from the website.

Now I have, when I (remote) connect true the Virtual Machine Manager the following message.

“Booting from Hard Disk…” This message is there al the time, what can I do to fix this?

Are you sure you followed everything by the letter? What have you selected as firmware for VM?

Yeah… you are right, I didn’t use the correct bios. When I changed it it worked good.
Btw, thanks for the video tutorial :slight_smile:

1 Like

Thank you :slight_smile:
BIOS is most common error for this problem. And glad it was this as others are more difficult to pinpoint.

Has anyone had issues when running in Synology VMM that HA can’t access the Syno IP address?

For example, my Syno is 192.168.1.20, HA VM is .19. Using the “Terminal & SSH” addon, I can ping almost anything. I can ping other devices on my local network, I can ping Google, but I cannot ping 192.168.1.20. Can anyone confirm this behaviour, or point me in the direction of a fix?

Do you have fixed IP addresses on those devices or are they on DHCP? Maybe Syno changed it’s IP? It’s a VERY good practice to set those IP’s to fixed, not DHCP.

@Protoncek All fixed IPs.