Installed local tuya via HACS but the integration is not available in Configuration/Integrations/add integration

So I’ve installed the local tuya integration via HACS… which seems successful… but the integration is not showing available in Configuration/Integrations when I go to ‘add integration’… what have i done wrong?

The documentation in HACS and in the repo shows how to configure it through text files.Not everything is available through the Web UI.

Is your YAML configuration not working? Please p[ost what you have tried.

Ah OK… it did feel like I was missing something (I am new to this).

So, I have downloaded the localtuya integration in HACS and restarted HA. I was following a Mark Watt Tech video on the subject - he seemed to do the same but the integration was then available in his Configuration where as in mine it is not? I was relying on the line in the repository under installation that said it could be installed via HACS?

PS… I have had the normal tuya previously installed which I have deleted.

After you restarted HA did you search to see if you could add it as an integration? I just tried on my test server.


Yeah, for some reason it doesn’t appear? It’s not in the list of available integrations.

Does it show as downloaded in HACS? Try clearing your browser cache like is recommended when you installed HACS.


Ah… yeah that seems to have sorted it… well I’ve tried from another device and it is available so much be the browser cache as you say. Many thanks! :+1:

1 Like

Although the tuya developer site seems to be down atm :man_facepalming:

Holy potatoes I’ve been running myself ragged on their site for hours. I finally gave up and put in a ticket. Is there a status notification for that? In other words, how did you know?