Installer for generic X86-64

Could you create a real installer for generic x86 image?

I have been following the guide here:

I have been trying for 2 days now to get a live linux to write the NUC image to a LattePanda V1 2/32 internal eMMC storage, and balena etcher hangs each and every time at 26%. Using a live Ubuntu 16.04 with etcher 1.4.9 (the only combination I could get to run properly on the LattePanda)

Would it be possible to just generate an installer image that could be burned to a USB stick instead of this very convoluted process that is seriously error-prone…I really would like to use the LattePanda V1 2/32 for Home Assistant, but I cant get the suggested process to work at all.

If anyone has a suggestion for getting the suggested process to work, I am all ears.

Thanks!

Try dd, it is pretty failsafe.

Thanks. I am not very comfortable with command line editing - could you point to a ressource describing the DD process?

Assuming the internal storage is /dev/sda, you’d do something like:

wget https://github.com/home-assistant/operating-system/releases/download/9.4/haos_generic-x86-64-9.4.img.xz
xzcatt haos_generic-x86-64-9.4.img.xz | dd of=/dev/sda

balena etcher hangs each and every time at 26%

That though would suggest a possible problem with your eMMC.

1 Like

I actually seemed to get it working now.

What I did: I loaded Gparted live and repartioned/reformatted the drive. After that I used Etcher 1.0.0 under live Ubuntu 16.04 to flash to eMMC drive, which completed fine and presto, home assistant started up.

I am figuring that starting off a completely wiped drive is what did the trick.

Thanks again for the help and suggestions :slight_smile:

I was having this exact same problem, Etcher kept hanging at 26%, I tried on 3 different PC’s with both Ubuntu 20.04 and 22.04 live USB’s. I eventually ditched Etcher and used the DD command instead.

@JussiH I believe what may have fixed it in your case was in fact changing to Etcher version 1.0.0, not the formatting of the drive.