Installing Home Assistant Core on CentOS/RHEL

:warning: This guide has been migrated from our website and might be outdated. Feel free to edit this guide to update it, and to remove this message after that.

To run Python 3.x on CentOS or RHEL (Red Hat Enterprise Linux), Software Collections needs to be activated first.

Using Software Collections

First of all install the software collection repository as root and scl utils. For example, on CentOS:

sudo yum install centos-release-scl
sudo yum-config-manager --enable centos-sclo-rh-testing
sudo yum install -y scl-utils

Install some dependencies you’ll need later.

sudo yum install gcc gcc-c++ systemd-devel

Then install the Python 3.6 package. If you are using CentOS 7 then you may have to install the packages for Python 3.6 using RHEL Methods listed here: for this to work as mentioned above.

sudo yum install rh-python36

This is part of the slight change when trying to install Python 3.6 and running the command python36 --version which will after install give you the correct version, but won’t allow you to set the software collection using the scl command. This command downloads the RH collection of Python to allow you to run scl command to enable the environment in bash and then run the automate command using the template.

yum install rh-python36

Start using software collections

scl enable rh-python36 bash

Once installed, switch to your homeassistant user (if you’ve set one up), enable the software collection and check that it has set up the new version of Python:

$ python --version
Python 3.6.3

You will be in a command shell set up with Python 3.6 as your default version. The virtualenv and pip commands will be correct for this version, so you can now create a virtual environment and install Home Assistant following the main instructions.

You will need to enable the software collection each time you log on before you activate your virtual environment.

Systemd with Software Collections

To autostart Home Assistant using systemd and a python36 (from SCL) virtual environment, follow the main instructions and adjust the template as follows:

Filename: /etc/systemd/system/[email protected]

Description=Home Assistant

# %i means the username is derived from the filename.
# a python venv for hass exists in /opt/hass/venv


This works because the Python virtual environment was created using the SCL environment, thus there is no need to activate SCL.

Running CentOS 7 here.
Had to run sudo yum install -y yum-utils for the 2nd step of your CentOS commands because yum-config-manager wasn’t installed yet.
Not sure if this a local setup issue for me, specific to CentOS 7, or something else, just thought it worth mentioning in case it helps anyone else.

This is waste of time, pip install method installs an ancient version of Home Assistant. This is not a solution, don’t waste your time with it like I did.