Installing Home Assistant on a RPi 4b with SSD boot

What controller does the inateck use? The issues that people ( a some group) were having with SSD lock ups were fixed December and released in January. This issues dealt with lockups.
Not booting almost always was a hardware issue with controller or SSD being incompatible with the RPI. I would search the RPI forums to see if your hardware is compatible. There are several good articles showing tested hardware.

1 Like

This was super helpful, thank you.
One thing (that may be too unrelated to mention, but I didn’t realise at first) is that the headless option for setup (over SSH) now requires another file, userconf.txt with the username and encoded password for you to sign-in with. This can be generated by the Raspberry Pi Imager when flashing the SD card.

This was announced on 2022-04-07, and has details in the Raspberry Pi News update.

I didn’t realise before flashing, so just copy-pasted the default user/password from a pi-hole forum post by jgpi250:


into a ‘userconf.txt’ file, alongside my ‘ssh’ file in the boot partition, and it worked like a charm.


Thank you so much for this great Guide! Especially keeping it up to date is really helpful! Switched to SSD-Boot with my RPi4 flawlessly. Took about 2hrs, and by now (3 Days) running with zero Issues! :star_struck:

What is your experience with SSD and Powercuts? I have my Pi running behind a UPS. Which is great, but draws about 110 KWh per Year. An Insurance im happy to pay, but if its more or less not necessary (any more), id love to skip it.
I don’t know how HassOS/HA on SSD behave with unexpected powerlosses. DB corrupt? Pretty possible. But would it reliable come up again, ready for restoring a Backup?

I’ve had no issues with mine after power cuts - RPI4 4GB + 250GB SSD.

Is TRIM a really big Thing, or can it rather be consider as ‘nice to have’? In Case not, is there (as of July 2022) a Way to Check / Enable Trim on Home Assistant OS 8.2?

which brand of SSD it is?
I have issues with ADATA 250GB

@Jpsy thanks for the guide, I’m working my way through it, but got stuck on something.

I have an Argon One M.2 case for my RPi and the SSD. That seems to work fine (I can see the SSD from within RPi OS when it’s loading from SD Card).

Unfortunately, it seems the M.2 expansion board cannot function as a SSD - USB for my macbook, which means I can’t image it using Balena for example. Can I image it directly from the Raspi OS? Any other tips (other than getting an extra SSD-USB) adapter?


You’re using a usb-a 3.0 patch cable?

Basically a USB-C - USB 2 cable that I use for data transfer from my phone, etc. Guessing by your question that could be the problem? If so, I have Sandisk SSD (wish SUB cable) USB cable at the office, so that might work?

Found the same cable at home, unfortunately it doesn’t work. It’s a USB cable for a sandisk SSD drive.

Any thoughts?

I have an argon the c didn’t work and usb a - a 2.0 didn’t work. It’s been over a year since I set mine up. There is an argon tread specifically for the SSD have you looked through that one, might be better to post to that as well.

1 Like

Thanks, that thread might help actually! Will try tonight!
Also just realised, the little A-A connector that comes with the case might actually fit into my mac adapter… Will update how it went.

Hello everyone,

It’s 2022 now. I wonder if you still need to do the step to install the Rasp OS and update the EEPROM. Or does installing the latest version of HA on the SSD will allow boot from USB straight away on rpi4 8GB?

This step can also be done with the Raspberry Pi Imager. There is a USB boot Image selectable. You simply have to insert the written SD card, wait until the green LED is flashing or a green screen is shown on HDMI and the shut the Pi off. Ready!
But newer Pi 4 should have the correct firmware.

I have it on my list for months now to ask Stefan @agners about this and to update the guide accordingly. From what I read I am quite sure that HA OS now contains the latest Pi 4 firmware and loads it itself. So the whole RPi OS step would be superfluous.

As soon as I get this information I will update the guide.

After 2 months I getthis error

This is meaning the ssd is broken or I’m wrong?

The only time I have seen this is not having a boot device connected (either SD or SSD).

Was this on a restart or it crashed with this message. You may try removing power from the pi and hub (if you use one) and then try restarting again. This error is not reading the boot information.

If you have a current backup, the fastest way back is reformat the SSD, install HA and then install the backup. Should be done in around 20 minutes.

In the night the system crashed 2 times then i pluged the monitor on and saw this messange.

I’m don’t sure if the problem was the ssd. After a clean installation on a new ssd all work like a charm.

I’m using the Argon M.2 case too. What I did is to install the M.2 SSD into the case, then use a USB 3.0 cable and connect directly from the Argon case to the my PC USB 3 port. The Balena/RPi Imager is able to see the drive. Don’t use USB2.0 cable, the PC can’t see it.

Hi, I just want to share my recent problem with the SSD so that anyone who bumped into the same issue might have idea what to check first!

My HAOS started having problem in reading the configuration file yesterday. And I can’t restart it as it keeps saying the configuration file is missing. I have been running SSD with RPi4 for a year and it is working at the while and survived multiple power dropout.

Then, I pulled the plug to do a hard reboot and ends up it can’t boot up anymore with the following errors.

At first I was thinking the HAOS was corrupted. I tried to reflash and but still, the HAOS doesn’t boot up with the same errors. So I tried to change the power supply and voila, it started to boot and took another 30 mins for the restore.

I were using the Argon official power supply and it is just like one year old before it’s started failing. I now switched to the official RPI power supply and so far it is running fine.

I should have try to swap the power supply at first before going to reflash the whole thing. :roll_eyes:

So anyone who might have the similar problem, just swap your power supply first and see it helps. I never thought the Argon power supply is dead in just one year!

1 Like