Installing Home Assistant on NUC using image

I am trying to install Home Assistant on my Lenovo ThinkCentre M92, but with no luck.

This is what I have tried:

This is the problem:
Error 1962: No operating system found. Repeat boot sequence automatically in 1 second.

BIOS does find the SSD.

Any alternative ways of installing or things I can try, that is a direct install on the SSD? I dont want Linux, docker etc. I have this today, and I am not satisfied.

Did you turn Off safe-boot in the BIOS?

I have to ask, what is lowering your satisfaction with this type of setup? I have had it running the same way (Ubuntu Server 20.04.1 LTS with Docker) for a long time now (even did a complete upgrade from Ubuntu Server 18.04 LTS) and haven’t had any issues.

It might be a bit subjective, but every now and then my system crashes. I think the cause is complex, but my lack of Linux-skills when things hit the fan doesnt improve the situation.

I have disabled Secure Boot in the BIOS. I dont have a Safe Boot, but perhaps the same thing?

Yes, most likely the same. I had difficulty getting an SSD boot, but eventually it worked on my i3 NUC.

Did you flash the NUC image directly to SSD or did you “install” it via USB?

I installed the image directly on the SSD using a USB to SSD cable.

The NUC image is designed for NUCs, not generic PC’s. You have 3 options on a generic pc.

  1. Supervised
    Installing Home Assistant Supervised on Debian 10

  2. Core (venv or Docker)

  1. VM (using something like Proxmox)
    Installing Home Assistant using Proxmox

Thank you!
Can`t believe I didnt get this! So many hours wasted.
Got Supervised running on Debian, as per your first link.

1 Like