Nuc install

Hello. I am currently using a pi. I purchased a nuc and downloaded the hass image for nuc burned to a usb drive and when I put it in the nuc this is the only screen that comes up

Connect a keyboard and press 1.

It just bounces back to same menu

I burned the NUC image directly to an SSD using an external SATA drive enclosure then installed it back in my mini-pc. Don’t suppose you have one of them lying around?

I am using an msata drive. I could purchase a sata ssd and try that

Is your NUC BIOS up to date?

Have you configured the BIOS boot drive order setting?

Is legacy boot enabled?

Is secure boot disabled?

No luck with that. With legacy set and secure boot turn off it doesn’t even see the USB drive

According to this page,

You should probably do the same settings as for the openelec boot. Step 6 probably doesn’t matter.

Tested with the development build at OpenElec.

  1. Press F2 when prompted during boot to enter BIOS Setup.
  2. Press F9 to set all BIOS options to default values.
  3. Select Advanced.
  4. On the Devices and Peripherals > SATA menu, Chipset SATA Mode is set to AHCI .
  5. On the Devices and Peripherals > USB menu, USB Legacy is enabled (checked).
  6. On the Devices and Peripherals > Video menu, IGD Minimum Memory is set to 512 MB .
  7. On the Boot > Boot Priority menu:
    1. UEFI Boot is disabled (unchecked).
    2. Legacy Boot is enabled (checked).
  8. On the Boot > Boot Configuration menu, USB under Boot Devices is enabled (checked).
  9. Press F10 to save your changes and exit BIOS Setup.

Proceed with the installation of the operating system.

However I’m still not convinced that the NUC image is bootable. I think it has to be imaged on to the drive.

Someone else with the same issue:

I really appreciate all your help. I unfortunately am still not having success. I looks like some people are having success burning the image directly to the sata card. I don’t really have a way to do that. And I’m not so sure it would work because if it would work why wouldn’t it just boot off this USB stick. I guess for now I will have to install Linux and Hassio in docker.

Have a read of this:

I was just about to tell you I had success with this. Booted Ubuntu and dd the image over to the internal drive. Works perfect. Thanks for all your help

Great to hear!

I can’t even begin to tell what an adventure I had to install hassos on a nuc8i5bek. Short story: NOT succesfull.

Why? just to try zwave native in hassos (instead of vera)

(btw, I don’t want ubuntu and hass, I don’t know linux that well (to manage etc.)

What I tried:

  1. try to get the NUC image on USB, boots up but same as above, only menu.
  2. cant get the NUC image on nvme disk (I literally tried all topics, all boot ISO’s, all commands, can’t get it to copy there.
  3. Tried virtualbox on windows, works well, but can’t get the vm to auto start or run headless…
    4 tried esxi, but ended up in the horror of network support (HCL), nvme drive support (NOT in 6.7, partly in 6.5 had to copy old nvme driver etc).
    Then I had it running (yippie) on vmware, put back a full HA snapshot and the horror of erros in grafana and influx came up… and could not get zwave working…

So now I am back at my original instance running on hyperv…

back to the drawingboard.

is it really so hard to have a hassos installer for nuc or other :-)?

1 Like