Installing Home Assistant OS using Proxmox 7

I went through 4ordy’s install processable above. Cannot get past the supervisor starting.

I think this has to do with my Netgear R6700v2 router Netgear GSS116E switch. Looking into that. I’ll update what I find. Just in case someone else is having this issue.

Failed for me at 3.1 but started step 3.2 up to the “click OK” and then selected >_Shell to open console as root. Then I followed the steps offered by mochman on Jun 9, 2021 here:

which kept me going at least through 3.8.

The script in 3.1 is working as intended. The script doesn’t use anything with file extension zip.

Gret Script and great Tutorial!
I followed every step and then i restored my last fullbackup from my previous rpi3. Since then i cant seem to find Supervisor anymore. The Addons menü does not list it anymore but it can still be found in integrations -though all its entities seem to be disabled.
I tried 'ha core rebuild command to restore it but with no luck.
Anyone else having this issue?

The Supervisor panel has been merged into the configuration panel. The separate menu item from the sidebar has been removed.

@kanga_who I suggest editing the main post and using @tteck ‘s script to install HA OS instead. It’s an extremely polished script, and more importantly the author is active both here and on Github, he is actively maintaining and improving the script, and if anyone has a specific issue with it, they will be able to get quick help. Worked like a charm for me, and I think it’s something worth considering, since Whiskerz007 seems to have stopped developing these scripts.

1 Like

It did that some time ago already :wink:

Oh wow sorry, I was deceived by the fact the instructions still credited Whiskerz007 for making the script, I assumed that was the script being installed in the post (I went to the bottom of the thread first and ran my installation directly from tteck’s repo because I assumed the main post was running Whiskerz’s instead. Apologies

Gave it a shot but hafter it extracts the image it errors out.

 ✓ Downloaded 8.1.qcow2 Disk Image
 ✓ Extracted Disk Image
 - Creating HAOS VM...‼ ERROR [email protected] Unknown failure occured.

That’s usually the storage you’re trying to use

https://github.com/tteck/Proxmox/issues/257
https://github.com/tteck/Proxmox/issues/253

Yeah I have a single “local” storage, no lvm

What type of file system are you using for “local”? ext4 | ZFS | BTRFS ?

edit: Just a note… the script doesn’t work with BTRFS or Pimox.

To be honest I can’t tell everywhere i looked it just says lvm. Just used the defaults when installing proxmox. I did combine both partitions into a single local partition.

Did you select the defaults when attempting to create the VM?

Yes I did.

After you combined partitions, did you add Disk image & Container to local?

Screenshot 2022-06-06 4.21.55 PM

As you can see, mine isn’t selected.

Yes all our selected actually.

Here is the error.

Creating HAOS VM…volume ‘local:100/vm-100-disk-1.qcow2’ does not exist
:bangbang: ERROR [email protected] Unknown failure occured.

Yeah, same as https://github.com/tteck/Proxmox/issues/257 (but had lvm to fallback)
I’m pretty sure it’s caused by the combined partitions. I’ve never tested that.

If I may ask, why did you combine?

fyi… cat /etc/fstab or lsblk -f should tell you