Installing Home Assistant OS using Proxmox 8

Hi @tteck ,

thanks for your quide! Unfiertunately I get stuck right at the beginning when it asks me to select a storage pool. It does detect my pool but pressing enter does absolutely nothing. Any clue what I can check or how I can solve this?

I installed proxmox 7 on a Fujitsu Futro S940.

Thanks in advance!

Run pvesm status -content images | awk 'NR>1' in the Proxmox shell and share the results

pvesm status -content images | awk 'NR>1'
Virgo_Backups        cifs     active      2808415520       219901380      2588514140    7.83%
local-lvm         lvmthin     active        72785920        15612579        57173340   21.45%

I need to install it locally so on lvmthin

Update: I disabled the cifs pool temporarily as I don’t have any containers or disk images there anyway to force the installer on the lvmthin and it worked… I got β€œcompleted successfully”

Something is going on with that but not sure what - let me know if you want to troubleshoot anything

Also thanks for the very fast reply

First thing I’d do is go to Datacenter > Storage click on Virgo_Backups then edit and unselect Disk image and Container. Then run the script again.

Yep, it worked, please check my reply above :slight_smile:

1 Like

@kanga_who’s guide, my scripts :stuck_out_tongue_winking_eye:

1 Like

I love you for this <3


I followed this really great guide to setting everything up and it worked great! Except for when the VM restarts, then I get a β€œa start job is running for wait until kernel time synchronized” making the system start wait for a 90 second timer before continuing.

I have seen other posts with this issue but haven’t found a solution to it.

Have you read

I hadn’t seen that one, the discussion revolves around network not being up at that point in time. But according to my start logs the Network Manager Wait Online finishes correctly.

In the logs I can see starting, stopping and starting Network Time Synchronisation again.

Do not know what this mean exactly, but I suspect this β€œonline” is not the same as β€œHAOS can now talk to internet freely.”
… which is what the network time sync needed.


  • Home Assistant OS VM
    • Option to create VM using Stable, Beta or Dev Image

Screenshot 2022-08-16 11.49.20 AM

1 Like

Note to self:

  1. when using this great script
  2. realising that there are some updates to ProxMox
  3. executing updates and getting the advice to restart, but postpone it because of 1)
  4. forgetting to restart and ending with a HAOS system that is very slow, addons won’t install or won’t start
  5. trying everything to get HAOS up and running

!!!REBOOT PROXMOX after updates :triumph:

  • Creating HAOS VM…:bangbang: ERROR 25@256 Unknown failure occurred

idea’s ?
edit I guess its from BTRFS being used

first time using proxmox and wanting to try out ceph as well
myplan is to get HA onto the laptop and start shutting down the servers as I only have a few hours to actually be on the pc hardly worth wasting 20kw running them

You’re running the wrong script. The is for PVE6 which has no BTRFS support.

Run the script posted in this guide ( for PVE7 and BTRFS support.

If you want to keep the screen closed on a laptop and not go to sleep

nano /etc/systemd/logind.conf


systemctl restart systemd-logind.service

And to save more KW turn the screen off

nano /etc/default/grub



Thanks I thought the v4 was for HA v4 not a script v4

now hitting a snag with the HA image that is set for 2 CPU while proxmox only allows 1 CPU per VM

How many available cores do you have?
It would appear that the machine you’re trying to use is a single core cpu.
Describe your system (laptop) I noticed in your first post that you were using BTRFS on PVE 7.2-7, and in this one your using EXT4 on PVE 7.2-3

all good stumbled across the menu that allowed changes to be made before it downloaded HA

currently using ZFS as this seems to be the only way for replication to work ,
think I have now reinstalled a dozen times

still unsure why I can never get the nodes to sync ,

not even 10 mins and it died on me

looks like you still need 3 machines for it to work so I might start renting a OVH seed box again for off site backups , hopefully they have now allowed VM’s in their bios’ only reason I stopped using them

thinking of going to the β€œHome Assistant Container LXC” route
only downside is I can not do a simple import from a backup
but hell it barely uses RAM / CPU