Installing Home Assistant OS using Proxmox 8

I used this guide and it has worked fine on a intel nuc.
But now I want to install HACS, I open shell for haos in Proxmox and there I type login. When I run wget I get wget not found. Then I tried to install SSH add-on but when I open configuration for the add-on I get “This add-on does not expose configuration for you to mess with…”
Does anyone know what I’m missing?

it could be network issues.

ZFS is required for Proxmox HA.

You need a minimum of 3 Proxmox instance to use High Availability (HA is confusing :slight_smile: ). I used to have a 3rd instance on a RPI4 just to have the corum.

I can unplug the Ethernet cable of the live Home Assistant and 2 min later it’s up on the new host. Totally transparent.

Hello all, I have a question about update Home Assistant OS (VM).
Some months ago I installed Proxmox with Home Assistant and lots of other apps using the scripts from @tteck.
Yesterday HA 2022.9 has released. This release relies strong on HA-OS version Operating System 9.
When i look at my system, it uses ‘Operating System 8.5’.
Can anyone tell me how to upgrade the VM for Home Assistant OS to the latest version?
I checked the description at tteck’s GitHub page but could not find this info.

Or, perhaps i have to backup the old VM and create a new VM in order to upgrade to HA OS v 9?
Any advise? Kind regards, Bert

This release relies strong on HA-OS version Operating System 9.

You’re incorrect.
The stable version of the OS is 8.5
The beta version of the OS is 9.0.rc1
The dev version of the OS is 10.0.dev20220907

1 Like

I’ve updated my Home Assistant Blue to 9.0.rc1 and now facing a non-booting system :frowning:
Any ideas how to solve this?

@tteck, OK, I am sorry, did not check that. But this morning I watched the Release Party (Home Assistant 9th Birthday Release Party (2022.9) - YouTube) and there they where talking about the new features for BlueTooth, and that they rely heavily on OS version 9. So i’l have to wait until that version is out of Beta,

But still my question remains, How can I upgrade a running VM to a new OS version?

You’ll get an update notification just like when core has an update.

1 Like

Correct, Bert, when the new OS is ready, you will see it. And you do that OS update from the UI of the HA.

No need to touch Proxmox or any console or any script.

OK, thank you for your info! And thank you very much for these wonderful scripts!
Kind regards, Bert

1 Like

Are you running Proxmox on the blue? Not sure why you would be when this device is designed to run HA OS only.

no, I just found this thread covering the RC1 release and hoped someone has an idea :wink:

I hope that you have a recent backup that’s not on the Blue, because you may have to re-flash.

I have :slight_smile: but I’m wondering what could be the issue, because even after rebooting 3 times, the system should rollback automatically, but there happens nothing :frowning:

How a Proxmox VM works is entirely different to the Blue.

1 Like

Not sure if this is a HASSOS issue or proxmox, but whenever I try to update HASSOS the system will disconnect (probably because it’s updating), but then will never come back up on its own. I have to force stop the VM and start it back up and then it’s on the latest version of the OS. Going into Console when this is happening doesn’t show anything so not sure what the deal is. Is there some setting I may have missed? I used this script last year, been having this issue ever since. Just leads me to not update as often as I should. Anyone else run into these issues?

1 Like

That’s before this guide started using my scripts (a lot has changed).
I’d suggest making a full backup of HA and download it.
Copy the MAC address of your VM and shut it down.
Create a new HAOS VM with the script above not using the default settings so that you can insert the MAC address from the other VM (this will keep the IP the same as the old VM).
Upload and restore the backup.
If everything is working as it should, remove the old VM (never run both VM’s at the same time)

1 Like

By not using the default settings do I need to change the script or do you just mean shut the VM down, edit the network settings to override the MAC address back to what it is currently?

When you run the script, it will ask you if you want to use the default settings, select NO

got it, thanks!