Installing Home Assistant OS using Proxmox 8

How did the update to OS 9 go?

thanks for checking! I haven’t done it yet, (didn’t even now it was out). I’ll try tonight and see how it goes and let you know.

1 Like

The HA Team just made a Revert β€œBump stable channel Home Assistant OS to 9.0” so you may have to wait for an update.

Edit: They just made a Revert "Revert β€œBump stable channel Home Assistant OS to 9.0"”
OS 9 is a go, again

It looked like it worked. I had removed some hardware but hadn’t shutdown/rebooted the VM so it had USB errors after the install and reboot, so I had to shut it down and reboot.

1 Like

So, all’s well now! :+1:

1 Like

Worked fine for me! :+1:


I’m facing same issue and tried just 1 hour ago to update rom 8.5 to 9.0 but I still get stuck.

As I read from your message, it should be all working after

Edit: They just made a Revert β€œRevert β€œBump stable channel Home Assistant OS to 9.0””
OS 9 is a go, again

Should I do anything before or after the update process?


The conversation between patmann03 and I starts here of trying to solve their issue of getting stuck after OS updates. Your issue may be totally different.

:arrow_right: If you installed HAOS using a script from this guide before May 3 2022, I’d suggest doing this.

1 Like

I haven’t used your script, but I used this script to create the HA VM.

I will try to check messages in this thread to see if it’s valid also for my issue


Pretty sure that is the script I used as well about a year or so ago. I do think taking a backup and rebuilding the VM with this script worked. I will know for sure next OS update.



I’m trying to create a new HA VM due to an issue updating my VM from HA OS 8.5 to 9.0

But I’m getting this error

Creating a HAOS VM using the above advanced settings
 βœ“ Using local-lvm for Storage Location.
 βœ“ Virtual Machine ID is 100.
 βœ“ Downloaded haos_ova-9.0.qcow2.xz
 βœ“ Extracted KVM Disk Image
 - Creating HAOS VM...400 Parameter verification failed.
name: invalid format - value does not look like a valid DNS name

qm create <vmid> [OPTIONS]
β€Ό ERROR 255@268 Unknown failure occurred.

It seems something related to DNS

this is my DNS configuration in Proxmox

Schermata 2022-09-17 alle 11.31.52

I haven’t used default settings in the script, to enter the MAC address of the other VM and I choose not to start the new VM automatically.

The script I’m using is
bash -c "$(wget -qLO -"

What else should I check?


What did you use for the hostname?

I used HA_OS

underscore isn’t allowed


HA-OS is ok, right?

yes, it will set it as β€œha-os”

Everything worked fine.
After the script, I’ve restored the backup from the original VM and it seems to work fine.

I will wait for a couple of days before deleting the original HA VM.


PS: Do you know any script or method to create a Node-RED LXC container in Proxmox?


I’ve updated my Proxmox from 6.x to 7.2 today and got the problem, that my hassos vm is not starting. After googling a bit, I suspect I need to disable secure boot but the problem is that I cant see anything in the console…

It just stays black, I even tried to setup a new vm but that doesn’t work either. Any idea how I can disable that?

Nevermind, apparently I just had to restart the whole server