Installing Home Assistant OS using Proxmox 8

I have 100% same problem, but it is actually not zigbee2mqtt…

Actually, have since found my issues were actually Proxmox 5.15 kernel and N5xxx series CPU support having several known “bugs” that are being addressed, but that cause lots of instability and locks up for VM’s - VM freezes irregularly | Proxmox Support Forum

I have been running now for four days rock solid, with proxmox snapshots (previously couldnt run for 24 hours). My N5095 CPU just need a later micrcode update to clear up problems.

Awesome script - I chose to go through the ADV setup - as I wanted to adjust a few things.

Only suggestion that I can see is about the network adapter choice. For example, I have this installed Proxmox with several other VMs (one of them is pfSense) and the PC has 5 NICs. The on-board NIC is the mgmt port for Proxmox – and that it where it tried to attach.

I prefer to have it attach to the LAN port for pfSense (was not a big deal) - just maybe a suggestion in your steps to check/confirm where the HA is connecting. :slight_smile:

But SUPER SIMPLE install with your script – thank you.

1 Like


I would like to install Home Assistant on Proxmox 7.2-3 following this manual.
But already at 2.1 I struggle. I can paste it into shell, but nothing happens…

Can somebody help me?

€dith: my bad…I had the wrong DNS… Sorry

1 Like

Again – I have to say that this script is very well thought out…however, seems that the ‘hardware’ settings could be better? Anyone else seem to think q35 for Machine - as everything I am reading this is needed for proper USB and PCI pass-thru ?

Please share your knowledge.

I use USB passthrough for both zwave and RTL_433 dongles and I’m using i440fx on my NUC with no issues. Can’t help with PCI passthrough.

I’d like to ask about implementation of the script. If I got some error, I just can assume it’s my proxmox setup fault right? :smiley:
Someone pls could give me an idea what to change?

Creating a HAOS VM using the above advanced settings
 ✓ Using local for Storage Location.
 ✓ Virtual Machine ID is 107.
 ✓ Downloaded haos_ova-9.2.qcow2.xz
 ✓ Extracted KVM Disk Image
 - Creating HAOS VM...400 Parameter verification failed.
efidisk0: invalid format - format error
efidisk0.efitype: property is not defined in schema and the schema does not allow additional properties

qm set <vmid> [OPTIONS]
‼ ERROR 255@262 Unknown failure occurred.

What version of Proxmox are you running?

Hi, thx for your answer.
It’s 7.0-11

It would appear that PVE 7.0 didn’t have the new schema defining efitype yet. :man_shrugging:

Beings that PVE is now at version 7.2-11, I’d suggest updating.

thank you very much for your answer.
I just did upgrade. It’s 7.2-11 right now and restarted.
The script getting ERROR.

Using Advanced Settings
Using HAOS Version: 9.3
Virtual Machine ID: 107
Using Hostname: homeassistant
Allocated Cores: 2
Allocated RAM: 4096
Using Bridge: vmbr1
Using MAC Address: 00:60:2F:63:54:73
Using Vlan: Default
Start VM when completed: yes
Creating a HAOS VM using the above advanced settings
 ✓ Using local for Storage Location.
 ✓ Virtual Machine ID is 107.
 ✓ Downloaded haos_ova-9.3.qcow2.xz
 ✓ Extracted KVM Disk Image
 - Creating HAOS VM...‼ ERROR 25@260 Unknown failure occurred.

Check and see if you have a stray vm-107-disk-0 present. If so, remove it.

Edit: Or, use a different VMID number

That was it.
Thank you very much!

✓ Started Home Assistant OS VM
✓ Completed Successfully!
1 Like

i copy and paste code

bash -c "$(wget -qLO -"

to proxmox shell, but promox no responsed. Test on proxmox 7.1-7 and 7.2-3

It requires internet.
Run this in the Proxmox Shell to test Internet connection

if nc -zw1 443; then  echo "Internet Connected"; else  echo "Internet NOT Connected"; fi; 

Internet connected.

Add code
I can use this method to install hass on 27th but yesterday and today can’t. I don’t understand it’s my proxmox or the download source

I just tried reinstalling it and it works

Pictures of text :-1:

Run this in the Proxmox Shell to see if your DNS can resolve to an IP address

RESOLVEDIP=$(nslookup "" | awk -F':' '/^Address: / { matched = 1 } matched { print $2}' | xargs)
if [[ -z "$RESOLVEDIP" ]]; then echo "DNS Lookup Failure";  else echo -e "DNS Resolved to $RESOLVEDIP";  fi

Glad you got it going

I would like to make a new install of my HA-setup and use a Dell MFF instead of RPI. At the time the computer only has an SSD, but I will add one more disc, probably a regular hdd.

I will install Proxmox on it and use it for Home Assistant, plex and maybe something more. I would appreciate some recommendations on where to place Proxmox and where to install my VM’s.

Use my 256GB SSD for Proxmox and the >2TB HDD for VM installs? Or install everything on HDD to avoid failing SSD?

I’d install Proxmox and use the SSD for everything, add storage later if needed.


This. Install the big HDD also but use that for backing up your VMs.

1 Like