Installing Home Assistant Supervised on a Raspberry Pi using Debian 12

I’m in the same boat with you, just screwed up my HA after update Raspbian.
Try many way (include reinstall) until roll back docker-ce to version 19.

apt install docker-ce=5:19.03.15~3-0~raspbian-buster docker-ce-cli=5:19.03.15~3-0~raspbian-buster

That’s it, reload Raspbian and supervisor back to start automatically !


I installed Docker using the convenience script. Now, when I run Aptitude to keep (the rest of) my system up to date, it suggests to remove docker-ce, docker-ce-cli, and with the remark “packages being removed because they are no longer used”. I guess this happens since the installed versions have been superseeded by an upgraded version, but the convenience script did install the packages without marking the correct dependencies.
What should I do?

  • mark the package docker-ce as manualy selected in aptitude (the other two depend on this one) so they are kept
  • just upgrade, let aptitude remove them, and suppose that they are kept because they were not installed through apt anyway
    The 1st option seems most safe.

Update: I did the first, and upgraded all with aptitude, after manually selecting the “docker-ce” package. At first, HASS did fail. But after a reboot, and some patience, everything is working again, and now it’s all running fine.
So maybe, as an additional step in the installation process, after running the ‘convenience script’, one should select docker-ce via apt, apt-get, or aptitude, or whatever package maintenance utility is being used.

Aaah thanks.
Just did it and everything is back to normal again luckily.

thank you

1 Like

This isn’t required as the docker install script pulls and installs the current/latest version.

It seems there is again an upstream issue with docker-cli causing an issue with the HA Supervisor. Downgrading docker-cli seems to fix this.

or as you have done downgrading to 5.19.x


But that is for the first install. Then you get the latest version. But upgrading Docker means the host version of Docker, not Docker in a Docker container. And the Docker installation on the host is managed by the host’s package management system, like apt or aptitude. And (at least on my system) aptitude was thinking Docker was no longer needed, when it started checking and noticed the version was outdated.
That is what I’d like to solve.

What are you on about?

If you install Docker on the host using the script, that’s all you need to do to run HA Supervised. You don’t need to update the Docker environment of a HA container.

I don’t have this issue on my test system using apt. Perhaps that’s an issue with Aptitude.

I think maybe he’s using raspbian and the docker convenience script? I think that has a different update method than apt-get etc? I could of course be totally wrong lol.

Hi there! Thanks for writing these instructions. I just followed all the steps and everything looks good except that wifi is not working anymore. I really wanna connect PI to wifi and I understand the risks and that LAN is more stable. During setup wifi was working fine, looks like HA’s installation script has blocked wifi interface or smth. Could anybody help me please?

What system are you using, Debian or Raspbian ?

Fresh Debian 10 (Buster) for Raspberry 3B+ from here.

Are you able to ping to your gateway ?
Is your WiFi not working for internet connection (ping or local area connection (ping to your gateway) ?

Can you show result of command “ip route”

Actually I was trying to connect via SSH previously with no success via wifi (for LAN it’s working). I connected monitor and keyboard to the board now and tried to ping. Network is unreachable. Attached the output.


How connect to your WiFi ? Looks like WiFi interface completely down, since there are no routing table.

Check your wlan0 status with command

ip a

If Interface down, bring it up with.

ip link set wlan0 up

Any try to re-configure your WiFi with network-manager by.


ip a


So here smth wrong with wlan0 as I understand. But it’s already up.


Tried it… There is no wireless connection option in “Activate a connection”.

Hmm strange :confused: I never have problem with WiFi in Debian with my Raspberry pi 3.
I mainly use WiFi for my Pi too.

Mostly I have problem with Raspbian since Dhcpcd conflict with Network Manager but I able to manage this so I stick with Raspbian since I’m familiar with this.

However, HAS installation script are modify /etc/network/interfaces. you may need to check this, or try to not modify /etc/network/interfaces during HAS installation prompt.

I configured manually wifi connection via network manager. Restarted the interface and it got ip address. I didn’t try ssh though. Restarted the board and wifi is gone again. It’s super strange for me…

Indeed, I use Raspbian. And aptitude, which was going to remove Docker. So I marked it manually as ‘keep’. But I did not pin the version, so apt(itude) upgraded the Docker version.
Everything works now, except that HomeAssistant does not start by itself anymore. hassio_observer starts upon reboot, but I have to manually start the homeassistant container (or was it hassio_supervisor?). I try to understand how Docker works, and how the different containers that depend on each other do start each other.
It did work, before upgrading Docker, so I would like to use the original startup mechanism, but I cannot find much documentation about how this convenience scripts sets-up things. On I read about using Docker-compose. Is that also what the convenience script uses?
Your help is very much appreciated.

There is a bug in docker-ce-cli in version 20.10.4 there is a link to a post with a fix here Installing Home Assistant Supervised on a Raspberry Pi with Debian 10