Installing Home Assistant Supervised on a Raspberry Pi using Debian 12

I’ve seen that somewhere else recently. Something to do with a network issue and the HA container not downloading correctly, can’t remember exactly. Try re-running Step 2.1 from the start again.

Started having issues once again after a couple hours due to the docker update. Retried one more time to re-install from scratch using these commands at the end and everything now works 100% successfully. Thanks!

Should be thanking this docker issue though, it forced me to redo my install and upgrade to a supported distro finally :joy:

1 Like

Thank you for this guide! It all went well for me except for minor issues (I needed to install sudo, wget, and unzip).

One problem came up, though. When the computer is rebooted, only the hassio_observer container automatically restarts. I can manually start the homeassistant and hassio-supervisor containers, and everything works. Did I miss a step?

Hello, for a fresh install of home assistant, this guide is ok???

Thank you so much. I thought my fresh HA installation was effed because I used the guide to install HA 64 bit on Raspberry Pi OS 64 bit.
In order to revive my installation I had to

sudo apt remove docker-ce docker-ce-cli
sudo apt autoremove --purge -y
sudo reboot

and now for the finale with a different minor version

sudo apt install docker-ce-cli=5:19.03.14~3-0~debian-buster
sudo apt install docker-ce=5:19.03.14~3-0~debian-buster
sudo apt-mark hold docker-ce docker-ce-cli
sudo reboot

After restarting HA showed the installation screen followed by the login but asked me to grant permission for using the current installation by typing my login.
Is that expected?
In the end I was greeted by the expected page of my configured devices.

1 Like

This sounds like the docker issue that has come up in the last few days. I would try running the docker version and steps in this post: Installing Home Assistant Supervised on Debian 10

The steps are already linked in this thread, post 42. :wink:

Yep, that did the trick, thanks!

With the previous installation, hassio_observer was running after a reboot, but not homeassistant nor hassio_supervisor. I could manually start them, and it would continue working normally. So maybe a minor configuration adjustment is all that is needed.

Excuse me if I repost my question…but I don’t know how to act for a fresh install.
Please anyone can help me???
I’ve to follow this guide???
Or After curl -fsSL | sh I’ve do downgrade before install home assistant?

Thank you

You can do this. Will work fine.

Thank you so much kalemba! Now work perfectly!!! Thanks again!!!

Thanks for the script. As a heads up, on my version (Pi4/DietPi), I had to install docker-ce-cli=5:19.03.14~3-0~raspbian-buster instead of debian-buster. Seems to have worked!

Nice that you got it up and running by installing docker-ce-cli=5:19.03.14~3-0~raspbian-buster.

But you are in the wrong thread. This one is about installing HA Supervised on a Raspberry Pi with Debian 10 but not with Rasbian Buster…

1 Like

Sorry for little OT.
I’ve installed Home Assistant Supervised, downgrade docker, now all is working fine.
Just an advice. I’ve to install a python program that i want control with Home Assistant.
I can install inside same docker, or I’ve to install outside???

1 Like

Don’t try to install anything in the HA containers.

You can install other software to the OS, but you risk your installation being made ‘unsupported’. HA will most likely still work, but you may/will get errors in the Supervisor.

Hi to all.
It got it working with the hints of Post 42.

Would it be a good idea to run pihole in an additional docker container next to HA?
If yes could someone be si kind and give me a hint how to do that in the best way because I do not want to crash HA.

Thanks a lot.

Ok, thank you so much for reply my question.
I’m a noob and don’t know if my ideas are doable.
For your experience, is possible to use shell command for start my program outside container???

You would be better off using the AdGuard Home add-on in the HA store. It works the same as PiHole, but available from within HA :wink:

I have a problem…
After installing everything, ha is working but when I restoring to my backup the system doesn’t working


You were right, I was running the pi on wifi but after connecting directly to the switch, the install script worked. It seems to be a problem with the network manager dropping the wifi connection when it restarts.

However I have a new problem, everything installed but I can’t get the webui up. I’ve left it for up to an hour after running the install script, but no luck.

When I list the docker containers, it shows all 6 containers running.

I’ve tried re-running the install script and have also downgraded docker following the posts above, but still no success.