Installing Home Assistant Supervised on a Raspberry Pi using Debian 12

Sorry for little OT.
I’ve installed Home Assistant Supervised, downgrade docker, now all is working fine.
Just an advice. I’ve to install a python program that i want control with Home Assistant.
I can install inside same docker, or I’ve to install outside???

1 Like

Don’t try to install anything in the HA containers.

You can install other software to the OS, but you risk your installation being made ‘unsupported’. HA will most likely still work, but you may/will get errors in the Supervisor.

Hi to all.
It got it working with the hints of Post 42.

Would it be a good idea to run pihole in an additional docker container next to HA?
If yes could someone be si kind and give me a hint how to do that in the best way because I do not want to crash HA.

Thanks a lot.

Ok, thank you so much for reply my question.
I’m a noob and don’t know if my ideas are doable.
For your experience, is possible to use shell command for start my program outside container???

You would be better off using the AdGuard Home add-on in the HA store. It works the same as PiHole, but available from within HA :wink:

I have a problem…
After installing everything, ha is working but when I restoring to my backup the system doesn’t working


You were right, I was running the pi on wifi but after connecting directly to the switch, the install script worked. It seems to be a problem with the network manager dropping the wifi connection when it restarts.

However I have a new problem, everything installed but I can’t get the webui up. I’ve left it for up to an hour after running the install script, but no luck.

When I list the docker containers, it shows all 6 containers running.

I’ve tried re-running the install script and have also downgraded docker following the posts above, but still no success.

Perfect - looks really great.

Thanks a lot!

May I install myself python in root directory that out of supervisor docker?

Leo Yang

Ok, finally seem to have fixed the problem. In case anyone else encounters a similar issue, the below steps worked for me - not sure if all are necessary but it got a result.

  1. Purged docker-ce
  2. Reinstalled version 5:19.03.14
  3. Stopped any remnant containers and removed them

sudo docker system prune -a

  1. Re-ran install script using only “raspberrypi4”

Last days I got several headpain with DNS issues after setting a static IP in dhcpcp.d. This static IP is always working however after a while the ping does not work anymore. Because in HA I got several error messages that URL loads do not work. It does not matter if the docker version 19 or 20. HA is always running regardless 19 or 20.

After re-installation with raspbian Buster 32 Bit + HA supervised, I tried to change IP settings in HA (Supervisor->System->Host System->Change IP). Suprised, I got 2 valid IPs: static IP and dynamic IP. HA will work with both IPs.

After a while the ping (or another IP outside local network) does not work anymore. A temporary solution is: sudo service dhcpcd restart

Who recognize / can help me to solve the static IP issue?

Applied parts:
RPi 4
SSD Kingston 120 GB + adapter ASMedia ASM115X (StarTech 2.5″ SATA, UGREEN USB)

I am unable to get my fan working through the gpio pins. Anyone know how I can activate?

1 Like

I would imagine you would need to use Raspberry Pi OS, or you may be able to download and install the necessary dependencies and drivers to make this work on Debian. How to do this is outside of the scope of this guide.

Sorry, also little off topic: Beside Debian arm64 will have future support for HA Supervised there is the big disadvantage that GPIO is not supported already in 64bit?

I noticed for example that Power Supply Checker Integration doesn’t work within HA.

1 Like

I had the same problem. Raspberry got 2 ips. Static and DHCP. Solved it by setting static ip in network-manager and then disabling service dhcpcd.

Without trying to pile on here, I’ll confirm some others experiences.

I’ve been running a supervised install since the summer on an RP4/8GB w/Ubuntu 20.04.1 Server (aarch64). I let the OS upgrade to Docker 5.20 and the install just s**t the bed until I downgraded.

Running another supervised install on another RP4/4GB, same OS, never allowed the Docker upgrade, it is doing fine. Docker 5.20 is not working with HA right now.

Is it possible to install HA on Debian without keyboard/monitor connected directly to RPi? Via SSH as it was possible on Raspberry OS.

If you update the Supervisor to the beta it will.

1 Like

Yes, but you need to generate SSH keys etc. Someone else has already posted above how to do this.

1 Like

@kanga_who, thanks! I expect I would update Supervisor first, then Docker?