Installing Home Assistant Supervised using Debian 12

Ahhhhhhh When you spend all afternoon head bashing installing stuff per the github page, writing your own install doc, and forget this page totally exists :man_facepalming: :man_facepalming: :man_facepalming:

Thanks for the doc guys and girls.


Thank you for this guide, it really helped me out as i’m super new to this.
If i may add a couple extra things i used, in case someone needs them, I might be doing something wrong,also regarding to ADR-0014 but, that’s how it worked for me:

During the installation, i removed the Graphical Interface part, as i dont needed, and checked the SSH server installation.
Once the installation is done, i log in through ssh and apt still has the cd-rom (installed the cd-rom version through USB) as a source so i removed it:

nano /etc/apt/sources.list
#add # infront of cd rom line to comment it out

Sudo was not installed for me so had to get it:

apt update
apt install sudo
sudo usermod -aG sudo <Whatever username you are using>

And an extra step for me, i’m on a laptop and want to keep the lid closed w/o suspending the system:

sudo nano /etc/systemd/logind.conf
#uncomment the line  and change it to ignore: HandleLidSwitch=ignore
#save, exit
sudo service systemd-logind restart

And then procede to section 2 of the guide.

Hope this helps someone :slight_smile: as ignorant as me.

Has anyone had trouble with high CPU usage from avahi-daemon?

Mine kept maxing out 1 core on my NUC so I have had to disable it, don’t know if this service is needed?

I’ve tried this a few different ways and keep hitting the same wall. When the daemon.json is created and docker is stopped then it cannot be restarted. Is there a script that doesn’t create this file? There appears to be a conflict with overlay2 and zfs.

Anyone figured how to enable UART on debian 10 - Supervised on raspberry 4?

This is not the guide for Raspi 4. Check here for Debian on a Pi, but to the best of my knowledge, you need to run Raspberry Pi OS, which is unsupported.

1 Like

thanks. and sorry for offtopic.

Can anyone help me with the error “missing docker”? I have install the Hassio with the tutorial in post 1

I use Debian 10 on Proxmox

Out of curiousity, why are you following these instructions rather than:

Because Proxmox is a hypervisor and Linux is just a Linux distro in its own right? Why shouldn’t that work with it? It would be the same if I installed the Linux distro on a normal computer.

are you trying to install on a debian lxc under Proxmox …or are you trying to install on a Debian system with proxmox added and running under debian?

please can somebody point me to the right direction?
I have installed the supervised version on Raspberry Pi 4 using but some of my containers keep restarting forever:

920ddf0ef49e   homeassistant/aarch64-hassio-dns:2021.01.0               "/init"                  21 seconds ago   Exited (159) 19 seconds ago                                              hassio_dns
4db05ca8b647   homeassistant/aarch64-hassio-observer:2020.10.1          "/init"                  24 seconds ago   Restarting (159) 1 second ago                                            hassio_observer
20b2cd234254   homeassistant/aarch64-hassio-cli:2020.11.1               "/init /bin/bash -c …"   28 seconds ago   Exited (159) 27 seconds ago                                              hassio_cli
fad7cedd7736   homeassistant/aarch64-hassio-multicast:3                 "/init"                  33 seconds ago   Exited (159) 32 seconds ago                                              hassio_multicast

This results in DNS problems that cripple the functionality. Any idea what might be wrong?
The logs are not very informative, it’s just “Watchdog detected problem with DNS/multicast/…”

Its a Debian VM on Proxmox

I have RasbP 4 to run homeassis. sometimes i need try some configuration on homeassistant and everyone know had some risks for trying somethings on hassi.
I had old toshiba laptop, working with raspbian smoothly.
How can i run home assistant supervisor in laptop… Here my system working in laptop.
Host: raspberry Kernel: 4.19.0-8-686-pae i686 bits: 32
Desktop: LXDE 0.10.0 Distro: Debian GNU/Linux 10 (buster)

Is there a way to run home assistant with this laptop… I tried somethings except virtual machine, all fail… Thanks

Has anyone upgraded docker to 20.10.3~3 yet?

Yes yesterday. All good.

1 Like

I followed this tutorial, thank you to everyone who contributed.
I have a Debian 10 VM on a Synology NAS, 2 processors, 2 GB of RAM. Home assistant (core) startup and restart time seems very long to me. It is at least 5 minutes in the best case, more often around 15 to 20 minutes. I created another post to ask if this time was normal and I was told no, with restart times <1 min.
What could this be due to?
Thank you

I could only run i2c using raspi-config

This guide is an excellent resource, thanks for writing this.
I have managed to install this on my old laptop after getting tired of SDCard issues on my RPi3, but after running it for a day or so, I am noticing really high CPU usage, averaging 50%! I tried to look at the host system processes using “top” and Node/npm were standing out at running frequently at >100%.
I am not sure what it was for, tried removing and stopping few addons, but I do not see any improvements. Anyone else observing this.

Update: I stopped all addons and now the CPU is hovering around 3-5% mark. I guess I will have to go by process of elimination to find out the culprit, unless someone has a smarter way to find it out

So Home Assistant Supervised on Debian 10 has been humming along ok for just over a month now. I’ve still got a handful of zwave/zigbee devices to add to the existing 50 or so of each, and then some automations/scripts to do.

Right now - the PC is an i5-2500 with 8G/ram.

Do I need to upgrade this PC to a more powerful one, or add ram? Or is what I have good enough for whatever I want to do with HA.