Installing Home Assistant Supervised using Debian 12

I just saw that the official supervised documentation list a new requirement: Home Assistant OS-Agent
Any one here has experience with this?

@wbravin - if you’re struggling a bit, I would install Virtual Box onto your Linux Mint installation, and then import the prebuilt image, which is found here Alternative - Home Assistant (first link) …

there are some pretty thorough instructions on how to set it up, and you should be good to go. I run my installation in Docker, but that suits me, as I’m a tinkerer, and also run other containers on my NUC, such as a virtual TV tuner for my Plex server, and a few other things…

Hello all

Just an update.
After struggling for a long time an going through a steep learning curve (very slowly) during the last 2 weeks I decided to reconfigure my laptop.

Hence i installed debian 10 with cinnamon (it took me 7 re-installs to get it right) and i installed HA supervised. and all works well. Thank you for all your help.

I connected an Aotec gen 7 z stick and am using z-wave js as the plugin.

I still need to learn how top properly develop HA

For now I thank you all for your patience and help in the matter


Good to hear you persisted with Debian and had some success :+1:

1 Like

Thank you for the guide. I wanted to move from Proxmox installation on NUC to Debian + Docker to be able to install Coral M.2 module and use if with Frigate NVR add-on. Followed your guide and installed everything without any problems.
The only thing - the stable Debian release is version 11 now, I installed the latest version. I think the guide can be updated with new file names and Debian version 11.

Debian 11 is still not a supported OS for Supervised. We are just waiting…

And with the next Supervisor it will be supported. Just announced today.

the only thing I’ve found that breaks in Debian 11 is the Portainer supervisor addon.

Update: For some unknown reason, this morning the addon works normally. AFAK, nothing changed overnight but it’s not longer an issue.

Not broken for me and it doesn’t even make sense that it would be

Hi! I have installed debian 10 and cinnamon too.
And have error at last step, when trying to execute this command:

curl -sL "" | bash -s

can you please advice what to do with an connection error?

you must have skipped a step…go back and follow the instructions exactly.

no skip. already tried three times before to write this topic on forum. maybe any else ideas?

try installing with gnome…your problem may be the desktop you’ve chosen.

ok. will try.

Hello all

I do not think that i will add much to this discussion. the only thing i can do is share my experience going from 0 knowledge to 1 in installing debian and HA… i am by no means a hero yet.

As i mentioned it took me 7 rebuilds of my laptop to install debian 10 and then i struggled for 2 days with the installation script. I succeeded

I am running debian 10 with cinnamon

the only wisdom i can partake is to check and re-check you syntax your line and character spacing and most of all be patient and let the processes run their course.

once i did this it worked

sorry for not being of more help

Hi, Installed the SSH and WEB terminal in supervisor. Can i use this keeping Debian 10 updatet? and how?

I can not run the “sudo apt update…” command, it returns apt: command not found

You can’t use the addon for that. You have to run the update command on the host.

1 Like

If you use the SSH terminal from the supervisor it will create it’s own docker container with it’s own resources. It’s not really helpfull in the way you might think.

It will SSH into the docker container (You would assume you have a SSH session to your host, but it’s not, it is an empty container) instead of the host machine. Usually any changes you make in that container will revert back to it’s original settings when the container is restarted (unless you use volumes or host mounts. But that is not the default setting). You can’t make changes to the general settings on the host from a container… this is just how it works)

It’s better to use putty on your windows machine and SSH into the host ip/hostname. If you are using linux as your default operating system of your laptop or desktop you are golden! You probably do not even have to install an application as you can use the terminal (referred as the command prompt in windows (or powershell)). In my optionion it’s far more advanced then just using putty and a windows machine. You will learn linux much faster if you ditch windows from your main machine :slight_smile:

In conclusion. You can’t use a container to update the host as docker containers are usually separated from the host… You have already demonstrated this yourself… The apt-get command does not work on the SSH terminal container because it’s not installed in the container because it’s basically a small installation of linux that only has the required software installed to make that container work (if the container only serves a webserver it will usually only have the HTTP server installed. if it does MYSQL it only has the bare minimum and the MYSQL server installed)

Sure enough, you can install apt(-get) on the container but it will only try and update the software in that container (not the host). Once the container restarts the apt(-get) is gone again. The container will get rebuilt completely as it restarts.

Not really. The HA containers are built on alpine linux, they don’t use apt. You need a debian (derivative) to use apt(-get)

That is totally correct.


I stand corrected. :tophat: