Installing Home Assistant Supervised using Debian 12

Wow that was quick Thank you

However I must not have been clear sorry for that.

|I was asking If I install Raspbiad (the os for the P4) on a laptop would I be able to install HA OS

I am asking if there would be an issue with this configuration

On a side note Home assistant developer should simplify their offering (say Core or OS) and let these be installed on a VM or docker environment. Since VM and docker are built to work on most platform (win, Linux, Raspbian and others) there would be no need for all these videos and solutions. They should use the KISS system Just a gripe

Anyhow thanks for the reply

HAOS INCLUDES the operating system. No Mint or Debian or anything else needed

thank you for your reply

as this laptop will only be used for HA this would be fine.

can you please guide me on where i could find a step by step process to

Thank you for your patience in this regard and your help install this on a virgin laptop

The very first message in this topic is a step-by-step description how to install Debian and HA Supervised.

If you want to install HA Supervised, this guide is the step by step process.

If you would like to install HA OS, then use the official instructions on the HA website HERE

Hello

i have been trying to follow your directions to no avail.
ted documentation i s
Due to my lack of knowledge and the limited and confusing documentation (and videos) i see:

I am getting frustrated and fed up with trying to install home assistant.

I am currently non vera home assistant and the only issue i have is that their geofencing is working incorrectly for me.

I have only a windows 10, windows 7, linux mint 20 and freenas as possible systems.
I tried to install debian on an HP elitebook 2170p which I am willing to leave always on.

For me it was very complicated to install and configure (i gave up)
The only reason is to have a better configuring geofencing app than vera who is currently limiting the geofence to 250 meters and remote access

I find the home assistant app limited in documentation and confusing in various youtube videos .
MY recommendations would be

that since Docker Virtual machine and virtual box can be common to Windows mac, linux debian, raspberry Pi and other then it would be simple to make HA fit in one or the other VM and that is it. There fore no one sill say that OS does not need an underlying OS

Then all the videos and blogs i cannot follow and is confusing.

I am willing to dedicate a nHP elitebook 2170p. I can install windows 10 or linux mint (i am getting quite versed in linux mint) not debian

I have the following requirements
Control media centre via amazon echo
HVAC controlled via sensors
geofencing controlled by presence and mobile phone

When home I would control it with echo or mobile app
Monitor power consumption base upon controller
and some simple scenes

all in z wave
I would like to know for my last effort

What home assistant solution i need ( in my opinion Supervised)
a simple pragmatic complete and effective step by step process on how to install HA

I thank you all for your understanding and patience with me

If you are struggling to install Debian, even with the instructions in this guide, then I do not recommend Supervised to you.

This guide does that and has been successfully followed by many people.

I would suggest if you know how to install and use Linux Mint, then install that on the laptop and install HA Core.

You could also install HA OS as I suggested in my previous reply to you.

Thank you @kanga_who

Thanbk you for your continues patience with me

I see this but this is for intel NUC which i do not have or ubuntu

So I presumed that as long as i set the UEFI and the secure boot as mentioned on my elite book I would be fine .

I downloaded etcher on my main laptop (windows 10) inserted a new usb drive and formatted it

used Balena and pasted the url as per documentation and flashed it to the USB simple as pie

However when I inserted the drive on the elitebook and changed the boot option to boot from the usb I just get the HP logo (from the boot process) and its been sitting there for the last 15 minutes.

The elitbook does have mint installed on the ssd (if i remove the use and reboot the laptop it does load mint.

what am i not doing or doing wrong

once again thank you

No, it is for “Generic x86-64” stated at the top of the page. The example shown is a NUC.

You don’t need Ubuntu.

“As a next step, we need to write the Operating System image to the installation media. Depending on your system this can be a S-ATA hard disk, S-ATA SSD, a M.2 SSD or even a eMMC. Home Assistant Operating System has no integrated installer. You need to use your Desktop computer (e.g. by using a USB to S-ATA adapter) :point_right: OR :point_left: boot a live operating system on your target system to install Home Assistant Operating System”

You need to flash to the drive you intend to use in the Laptop (the SSD that has Mint).

Being that this thread/guide is for Installing Debian and HA Supervised, if you are still having problems I would suggest starting a new thread so as not to confuse others visiting this one.

Every time I have set up a linux machine I just boot off the OS ISO… eg Debian ISO and install to system from that. It’s normally simple to use Win32DiskImager or Etcher to make a bootable USB.

I must say I’m mystified that @wbravin has no problem installing mint but struggles with debian…

2 Likes

Hello all

First let me all thank you for you time and support

Last night i flashed the ISO (as described both from you all and from the documents) with etcher on my production laptop (win 10) to a new fully formatted USB

@kanga_who just now do i understand that i need to download and cop the HA file to the usb and the use etcher to install it to the ssd correct

I inserted the USB into my elitebook (currently it boot up from its ssd in linux mint) and rebooted the elitebook it did not work.

@DavidFW1960 As my frustration increased because of my lack of knowledge, I decided this morning to install supervised on the linux pc. It has install correctly and now i am in the process of configuring it.

I have a hard time with debian because:
1 I’m old (70)
2 I’m at the early stages of altimeters
3 i am dyslexic
Therefore in the mint gui i can cut and paste (without understanding what i am doing) ok
Debian is for more advance user or user who understand much more than i do

I know that the solution i installed is not supported

Once all configured and once i learn blueprints, automation scenes and scripts and i install and configure the aeotech gen 7 usb

I may move from my current setup to a debian solution

Regardless of this all Once again i thank you both for your help and patience with me

You may need to set the USB to be the first boot device in your BIOS. You can sometimes set a one-time boot option by pressing something like F12 or DEL, it quickly flashes up on the screen when you power on the machine.

Good on you for giving it a crack then :+1: I think for simplicity, the best option for you will be to install HA OS.

hello Thank you

I did set the first boot the use both from the bios and from the boot screen by pressing ESC and the F9 to no avail

However thank you for your help How can i buy you a beer to show my gratitude

It is difficult to find someone willing to sell a bear…but if you do, it’s a phenomenal gift.

I just saw that the official supervised documentation list a new requirement: Home Assistant OS-Agent
Any one here has experience with this?

@wbravin - if you’re struggling a bit, I would install Virtual Box onto your Linux Mint installation, and then import the prebuilt image, which is found here Alternative - Home Assistant (first link) …

there are some pretty thorough instructions on how to set it up, and you should be good to go. I run my installation in Docker, but that suits me, as I’m a tinkerer, and also run other containers on my NUC, such as a virtual TV tuner for my Plex server, and a few other things…

Hello all

Just an update.
After struggling for a long time an going through a steep learning curve (very slowly) during the last 2 weeks I decided to reconfigure my laptop.

Hence i installed debian 10 with cinnamon (it took me 7 re-installs to get it right) and i installed HA supervised. and all works well. Thank you for all your help.

I connected an Aotec gen 7 z stick and am using z-wave js as the plugin.

I still need to learn how top properly develop HA

For now I thank you all for your patience and help in the matter

3 Likes

Good to hear you persisted with Debian and had some success :+1:

1 Like

Thank you for the guide. I wanted to move from Proxmox installation on NUC to Debian + Docker to be able to install Coral M.2 module and use if with Frigate NVR add-on. Followed your guide and installed everything without any problems.
The only thing - the stable Debian release is version 11 now, I installed the latest version. I think the guide can be updated with new file names and Debian version 11.

Debian 11 is still not a supported OS for Supervised. We are just waiting…

And with the next Supervisor it will be supported. Just announced today.