Installing Home Assistant to a NUC - no success

Sorry if this question is already answered, butI have searched the forums and the Discord channels, but I got nowhere closer the solution yet.

So: I have tried to install Home Assistant (Supervised) to a NUC, but I can’t make it work from the docs.
I therefore ended up with a Debian / Home Assistant which works great, but since I’m a total Linux noob, that’s not my preferred way.

So from todays announcement, I thought I should make it work and maybe clarify the docs since I guess there are more like me out there.
But to do that, I need help to make it work at first :slight_smile:

The docs says:
2. Install Home Assistant:
Flash the downloaded image to an SD card using balenaEtcher. If using a Pi, we recommend at least a 32 GB SD card to avoid running out of space. On Virtual machine platforms, provide at least 32 GB of disk space for the VM.

I have tried the Pi/SDcard install which is super smooth, but is this valid for NUC as well?

Coming from a Windows/PC-world I am used to make a bootable USB-drive, boot from that, select the target (NUC SSD-drive) and just Enter-Enter my way forward.

I got no problem flashing the NUC image to the USB, but when booting from it I got 4 options that says something like this:

  1. Auto-install
  2. OS 1
  3. OS 2
  4. Shell

And none of them gets me anywhere near an installation, so I guess other steps are needed.


Is this the place to go on or should I open a forum thread instead?

What you have to do : remove the HDD/SSD from your NUC, attach it with a USB->SATA cable to your PC and flash the image with Etcher on your HDD/SSD. Then put it back in your NUC.

Wow, that was fast and seems pretty easy.
I don’t have a USB -> SATA cable but that’s easily solved, just not today :slight_smile:

Is this to be considered the preferred way to go?
I’m fine with it, I just think it’s strange there’s not a word mentioning that as far as I can see.

Just replace SD with HDD/SSD :slight_smile:

You missed step 5:

Cross your fingers and hope like hell it works.

First PC I tiried this on it works no issue. The second one…

I spent days trying to get the NUC image burned directly to an SSD to recognise the PC’s NIC. Ended up having to install it as per the now unsupported option which worked first go. Go figure.

1 Like

You can always download and install Ubuntu live on an USB stick, boot your NUC and then download and install the image onto the SSD/HDD.

1 Like

I’ve had good results with using gnome-disks to ‘restore’ the downloaded image to disk instead of etcher

Just a live linux usb, start gnome-disks > restore image > startup gparted to check/set disk has bootable flag > reboot

I never even took out the disk from my nuc, i’ts an m2 and I don’t have an adapter for it…

1 Like

Seems there are no one way. But a good starting point is to search to see if other threads are dealing with this. And indeed there is: My steps to success for on Intel NUC

I managed to get I working after inspiration from that thread, and, like others, described what worked for me.

Good luck:-)

Leave everything in the NUC and just download the live Ubuntu image. If you have at least 8GB RAM, you can do everything inside Ubuntu live. You can download the image and then use the Gnome disk manager to write that image straight to your SSD. Read down from here and my notes below that.


Thanks all for your input!
I tried the cable/flash method yesterday without success.

Will try the Ubuntu Live tonight!

Why don’t you install Proxmox and after that, use Whiskerz007 script to install HassOS?

Just a point of clarification…

As far as I read this thread you aren’t trying to install “Home Assistant Supervised” to your NUC.

You are trying to flash the “intel-NUC” image to your NUC SSD.

When you do finally get that accomplished you will end up with “Home Assistant” (not Supervised). It will still function exactly like the “Home Assistant Supervised” install but it’s just called something different because you installed it in a different way.

I know it doesn’t really make sense but It’s all in the new naming convention.

HassOS. :wink: