Installing program to a ESP32

I have installed ESPHome in my Home Assistant instance over 6 months ago and I have never been able to install any program to my ESP32.

My Home Assistant is running on Raspberry PI 4.
I am accessing Home Assistant via the Application Home Assistant on a MAC

I wrote a very basic program for my ESP32. Basically just giving my ssid and password to access my network.

I selected the option “Plug into this computer” to install this on your device.
I receive a message that not all requirements are currently met. ESPHome is visited over HTTS and my browser support WebSerial.
I don’t know what “visited over HTTS” mean and I am using Chrome as my default browser on my Mac. Can any one explain what this means.

I also try the option “Plug into computer running ESPHome Dashboard”, I assume this is my Raspberry Pi. I receive a message to “pick server port” with two selection. TI CC2531 USB CDC and ttyACM0. I try both after connecting my ESP32 to the PI I got the same “fatal error” for both.

Any help would be greatly appreciated, I don’t know what to do.

It says https not htts. Does the url you access ha start with http or https?

Not using a MAC, but I just went through this exercise with a Windows PC. In my case, there was a need to install a driver on Windows. Once installed, ESPHome worked great. Do MAC’s require drivers in order to see your ESP32? My first project has been uploaded to an ESP8826 and is working.

If you have a nabu casa account and are using the addon you can use it to get esphome over https.

Neither, I am using Home Assistant application IOS Companion.

I don’t know about driver on MAC, anyone know? If so which driver should it be?

Are you using esphome via the addon? Or did you install it yourself some other way?

Idon’t have a nabu casa account. I am using. I installed DUCK DND, about 18 months ago and I use it with IOS Application Home Assistant to access my Home Assistant server.

I did install it via add-on, I think. Is is on my menu on the left hand side.

Ok back to the pi.

If you plug the esp32 into usb on the pi, then run dmesg you should see what serial device it is mapped to.

I am sorry, but I don’t know how to run « dmesg » I installed Home Assistant with a micro sd card. I have no keyboard or screen to see it. Could you elaborate, this is probably basic to you but a total challenge for me.

Add the ssh & web terminal addon. Ssh in. Run the command.

I used the Terminal application on my Mac. I entered SSH “enter” and then dmesgl.
Answer: “Unable to obtain kernel buffer. Operation not permitted”

Are you ssh’d into the pi?
Why do you use dmesgl when the command is dmesg?
Do you have the ssh & web terminal addon installed on the pi?
I am almost to the point where I think you are deliberately trolling

Sorry about dmesgl was a keyskote errror. I did dmesg.
I don’t know if I have ssh and web terminal install on my pi. Does this comme with the installation of Home Assistant?

Sorry for my limited technical knowledge. I have learn a lot using Home Assistant and installing different components, But going directly within the pi, I have never done or maybe without me noticing.

I dont know if there are limitations using the iOS app running on a M1 based Mac. You may want to try accessing Homeassistant through Safari or Chrome by going to http://homeassistant.local:8123 or https://homeassistant.local:8123 One of those should bring you web access to your Homeassistant instance.

I would make sure Homeassistant is up to date on all fronts and ESPHome is updated to the latest version.

I have found the easiest way to get ESPHome projects up and running is to plug the microcontroller directly into the computer Homeassistant is running on, in this case, your raspberry Pi.

You MUST compile your ESP device’s code first and then you need to upload using the plug into computer running ESPHome dashboard option. pick your serial device from the list, if you’re unsure, unplug the ESP32 device, refresh the list, see which one disappeared, plug back in, choose the one that disappeared in the test. It should upload no problem and then your device should connect to wifi. Once connected to wifi you can edit the code for the device and upload changes using the wirelessly method instead of plugging into the Pi.

Thank you for your detail answer. It is late over here. I will try your proposal tomorrow .

Resolved, a failing cable.

Some cables are for charging only and don’t carry data.

Some cables are broken.

Always try more than one.

Actually HTTS is correct. I have an error currently that specifically says “HTTS”. Just because everyone’s used to seeing HTTPS doesn’t mean HTTS is wrong.