Insteon Integration PLM USB Device Path Question

Hello all,
I’m a long time HomeSeer user with a robust Insteon network in place and was recently looking at Home Assistant as a potential new automation option. I wanted to test a side-by-side installation of HS and HA and got up an running with an HA instance installed on the same windows 10 machine running HS.

I followed the steps in this video to setup HA in a VM using VirtualBox and was able to get this started and connected via the web interface. I was then trying to add the Insteon Integration when I hit a snag and was hoping someone may be able to help me.

I have an Insteon 2413U PLM connected directly to this windows machine and selected that as the ‘Select the Insteon modem type’ value when adding the integration, but then on the second modal screen where it asks for the USB Device Path I am lost. I am not quite sure what I should enter here but have tried several attempts and keep getting a connection error.

I can see the “Device Instance Path” in the host windows machine’s Device Settings -> Details page and tried that but no success. I am not sure I am correctly passing through the USB device from the Host to the VM either as my VM experience is light.

  1. Should the USB PLM be passed through as a USB or Serial device? The PLM looks to show up in the host machine on COM7 and as I do not see it listed in Virtual Box -> VM -> Settings -> USB -> as an available USB device I am not quite sure how to pass it through or if I should be looking in the Virtual Box -> VM -> Settings -> Serial Ports-> tab.

I greatly appreciate any help folks can lend. Let me know what I can share to help narrow this down.

I have EXACTLY the same question. Can anybody shed some light on this?

Hey @carealtor,
I recently came back to this project and forget where I asked but I got the answer I was looking for.

With the home assistant instance up and running go to the Supervisor → System → log and then unplug the PLM from your machine. Look in the logs for an entry that says the device has been removed, it will give you the full Linux based device path ID which is what you need. Plug the PLM back in and you should see a similar device connected log entry with the same device path ID. Use that entire path string in the model pop-up of the integration set up.

Sorry I can’t recall where I came across this help, it might’ve been from a sub Reddit but let me know if you have any questions and I can go through the process on my end again to get you an example of what the device path ID, something like, “/dev/XXX/USB0/“.

1 Like

Finally played with this again tonight. Before this would work I had to enable Serial Port COM3 in the VirtualBox Settings for this VM. I could see it was COM3 by watching in the Device Manager of the host as I plugged in and unplugged the the Insteon USB PLM. Once I enable the COM3 Port in VirtualBox, then I could see what @Sinandgrin was describing and I got the Path that I needed. In my case it was “/dev/ttyUSB0”.