Integrating Becker Motors in to Hassio

I would like to thank every contributor on this integration it works very well !

M return of experience is :

  • installation and configuration is easy if you follow the instructions

  • I struggled a lot to make the integration work, because everything was set up properly, but the covers were not receiving any pairing confirmation during the pairing process. I had to move the usb stick far away from my Synology NAS and then it worked.

There is one feature for which I am still struggling : the cover up and down time.
I measured for one cover the up and down time and put it in the configuration. If I try to set a cover at 50% opened, it is not the case. In order to set it up more precisely, I had to increase the number of seconds for which the cover is going up and down, test many times by setting 50% and stop when the good position is found.

Is this known or did I do a mistake somewhere ?

What range do you guys get from the USB stick ??

With the 5 channel remote I can’t reliably control both of my awnings if I am next to one of them and they are about 10M apart,

I’m guessing what your issue might be.

The position is based on traveling time. Usually it takes some time for the slats to pull apart before the entire cover opens. This time is included in the traveling time. If it takes relatively long until the slats pull, the position does not match exactly with the opening position of the entire cover.
It doesn’t make sense to adjust the traveling time to compensate this. This will never lead to a good results, especially if you move from position to position many times consecutively without fully open or close the cover in between.

Assume the slats your cover takes 20% of the entire traveling time to pull apart. Setting the position to 20% results in the slats pull apart, but the entire cover is still closed. If you require the cover visually opened by 50%, you will need to set the position to 60%.

This limitation is also the case in other implementations.

If you use a 1m extension cable and place the stick at a good position away from your Home Assistent hardware and other sources of disturbances, the range should be similar as with the remote.
Running your Home Assistent with the stick in the basement to control your roof window covers might not work.

Hello again,

after using the stick for roughly one year now, I am facing problems with it. Every few days it stops working randomly and I have to disconnect and connect it again and reboot HA. There is no log entry that tells me there is something wrong and the sensor is showing the assumed state, but the shutters aren’t moving. I used it with a Raspberry Pi first, but I decided to move to a full PC. It occurred just before the move so I thought that it will be gone on the new hardware, but it moved with my HA.
Has anyone had similar problems or can tell me how to investigate the problem further?
Thank you in advance

Same for me but no solition found yet.
Running HA as VM on a Synology Diskstation.

I am glad to hear I am not alone. Do you use an extension USB Cable?

Yes, I do. This reduced frequency of disconnection but did not completely solve the issue.

Has anyone ever successfully tried the value_template with a sensor?
I tried with my Shelly DW2 attached to my rooftop window but wasn’t successful.
First, I used the original binary_sensor but this crashed the whole cover. Since the manual says values should be 'closed' and doesn’t mention 'off' like used by the binary sensor, I created a template sensor translating off into closed and on into open. Now the cover worked (received the commands) but position is always 0 and travelling times are not used. I tried other else commands for the value_template like unknown, state_attr of current_position of the cover or even no else command at all but nothing works. The cover is moving but position remains 0. Regardless the value of value_template (Null, "", 0, unknown… depending on the else argument).
Any ideas?

I have only done limited testing with the value_template. Please share your template.
The template will override the position estimated by the travelling times. What are your expectations regarding travelling times?

Regarding the disconnection issue, unfortunately I don’t have a good idea.

Same problem here. I noticed that in this case, there are also neither sent packet nor received packet log messages anymore visible (although I placed the remote close to the stick).

Hi everybody, I’ve just tried to add the becker integration with the following config:


unfortunately I get the following error in my “my-centronic-stick.db” file, which I’m pretty sure means I have an error in my config - Do you have any idea what I missed?

‘utf-8’ codec can’t decode byte 0xea in position 99: invalid continuation byte

Thanks in advance!

(In the log files, everything looks great and it recognizes any commands I send with the master remote)

The “my-centronic-stick.db” file is a SQlite database file and therefore not readable with text editor.
Is the value_template working for you?

Message in a bottle :
I bought the Centronic USB Stick and eventually got it to work with Home Assistant and my shutters via this wonderful integration. Unfortunately, I only manage to control 3 shutters out of 5 from the USB key. This is probably not linked to the project, but maybe somebody has the answer:

  • I have 5 shutters on the ground floor. I control them with a EC545 II remote (5 channels).
  • The first 2 channels goes to shutters 1 and 2. Channel 5 goes to shutter 5. They Work perfectly with Home Assistant, the USB key and this integration.
  • Shutters 3 & 4 are both linked to channel 3 (when I select channel 3 on the radio remote, both shutters move)
  • My problem is that for some reason I am not able to pair the 2 shutters 3 & 4 (when I click the small hole on the remote with channel 3 selected, no “clack” happens, neither on shutter 3 nor on shutter 4). Is it impossible to pair 2 shutters at a time ?
    An idea anyone ? Thanks in advance !


I have problem to integrate my BECKER R8/17 C PROF Motors.

I have as controllers :

  • One master EC541-II for each motor
  • One EC545-II For zones
  • One EC3111 set as general

I’ve got a 40350000410 Stick on 1meter USB cable just 2 meters far from the first cover i try to pair.
The USB Key is successfuly mapped from my synology to home assistant, visible in material as :

DEVNAME: /dev/ttyACM0
DEVPATH: /devices/pci0000:00/0000:00:04.0/usb2/2-1/2-1:1.0/tty/ttyACM0

I’ve integrated Becker cover support plus PyBecker with HACS successfully,

My configuration.yaml is :

  - platform: becker
    device: "/dev/serial/by-id/usb-Becker-Antriebe_GmbH_CDC_RS232_v125_Centronic-if00"
    filename: "my-centronic-stick.db"
        friendly_name: "Volet Cuisine"
        channel: "1:1"
        travelling_time_up: 13
        travelling_time_down: 13

In logs i’ve got at startup :

2024-02-10 10:06:04.502 DEBUG (MainThread) [custom_components.becker.cover] device: /dev/serial/by-id/usb-Becker-Antriebe_GmbH_CDC_RS232_v125_Centronic-if00; filename: my-centronic-stick.db

2024-02-10 10:06:04.503 DEBUG (MainThread) [custom_components.becker.rf_device] Use filename: my-centronic-stick.db

2024-02-10 10:06:04.504 DEBUG (MainThread) [custom_components.becker.pybecker.becker_helper] Try to open connection.

2024-02-10 10:06:04.512 DEBUG (Thread-4) [custom_components.becker.pybecker.becker_helper] BeckerCommunicator thread started.

I put motors in Prog mod with the master contoller, i heard the “clac” once.

I call Service :

service: becker.pair
  channel: 1
  unit: 1

We can see in logs :

2024-02-10 10:06:47.029 DEBUG (Thread-4) [custom_components.becker.pybecker.becker_helper] Sent packet: unit_id: 1737B, channel: 1, command: TRAIN, argument: 1, packet: b’\x020000000002010B00B70000001737B021010100819C\x03’

2024-02-10 10:06:47.131 DEBUG (Thread-4) [custom_components.becker.pybecker.becker_helper] Sent packet: unit_id: 1737B, channel: 1, command: RELEASE, argument: 0, packet: b’\x020000000002010B00B80000001737B021010100001C\x03’

2024-02-10 10:06:47.238 DEBUG (Thread-4) [custom_components.becker.pybecker.becker_helper] Sent packet: unit_id: 1737B, channel: 1, command: TRAIN, argument: 1, packet: b’\x020000000002010B00B90000001737B021010100819A\x03’

But i dont have any “clac” confirmation from the stick pairing.

Does somebody see what’s wrong ?

Did you restart after the initial configuration? I did a full system restart, not only HA.

Yes i did, several times…

Do you see log messages when you press any key on your remote (like UP, DOWN, STOP)? In debug mode all received commands are logged.
This verifies the proper connection of the USB stick into HA to distinguish wether there is an issue with the connection/stick or with training of motor.
Do you have right version of USB stick as mentioned in the readme?

Thanks for your answer @RainerS

When i press remotes i dont see anything in logs

I Have the 4035 000 041 0 stick, not the 4035 200 041 0 one
But i read that it was exactly same thing except the device name that is not full capitalized ?

Do you think that the problem comes from this USB key ?