Integrating Becker Motors in to Hassio

I do not entirely follow the channel/unit thing… On the Master remote, the topmost LED is lit up, hence CH1? What is the unit…? Is the Master Unit 1? The motor unit 2? In the pair example, the USB should be 1:1…
As you know, I do not get any signals into the log file from the USB - trying to find the error… But the USB should listen to and report any traffic going on, regardless of its own Channel and Unit, right?

each remote has a unit code. This is true for your master remote as well as your USB stick. A unit code consists of five digits, e.g. 12345.To make live easier, the unit code for the USB stick is simple 1 to 5.
In addition each unit might have several channels 1 to 7.
The motor is just a receiver and has no unit code.
Each motor can be trained for multiple unit:channel combinations.
The becker.pair service needs to be filled with valid data like:

service: becker.pair
data:
  channel: 1
  unit: 1

You can get this view by selecting YAML modus and then FILL WITH EXAMPLE DATA

Good morning, sorry for my late reaction. I didn’t have time to test it again within the last weeks. But today I tried it again and I’m not sure where the problem is.

First of all, thats everything I’ve written down within the configuration.yaml, concerning the Becker shutters:

################
#BECKER ROLLADEN
################

logger:
  default: info
  logs:
    # This must correspond to the folder name of your /config/custom_components/becker folder
    custom_components.becker: debug

cover:
  - platform: becker
    device: "/dev/my-becker-centronic-usb"
    filename: "my-centronic-stick.db"
    covers:
      # Use unique names for each cover like kitchen, bedroom or living_room
      buerodaniel:
        friendly_name: "Büro Daniel"
        # Becker Centronic USB stick provides up to five units (1-5) with up to seven (1-7) channels
        # Unit 1 - Channel 1
        channel: "1"
        # The travel time for direction up is sufficient if travel time for up and down are equal
        travelling_time_up: 3
        # Optional travel time for direction down
        travelling_time_down: 3
      bedroom:
        friendly_name: "Bedroom Cover"
        # Unit 1 - Channel 2
        channel: "2"
      living_room:
        friendly_name: "Living room Cover"
        # Use Unit 2 - Channel 1
        channel: "2:1"

I tried to implement the first shutter by bringing it into the “programming mode”, the shutter reacts with the typical “click”, so this should be ok.

After that I tried to run the “becker-pair” out of the services category of development tools and I only get the “unknown error”

By looking into the home-assistant.log file, nothing is logged concering this action/error

Any ideas who to go on?

Thanks

For me the “unknown error” was fixed by restarting the device the USB Stick was attached to (in my case a Raspberry Pi)

I finally managed to get it all to work using the stick bought from Amazon:
https://www.amazon.de/dp/B0983XS7ZG?psc=1&ref=ppx_yo2ov_dt_b_product_details

The only real oddity I noticed is when running multiple commands at once (e.g. voice assistant “shut everything”) only two of my four windows close. I’m wondering how I can ensure the commands are done sequentially.