Integrating Somfy RTS Shades

I have a couple dozen RTS roller shades around my house plus Phantom screens on my porch that use a somfy RTS motor. I’ve struggled to reliably integrate these in HA.

I bought a Somfy MyLink, it is a piece of junk. Unreliable WiFi connection, junk app, and unreliable opening/closing of shades.

I looked at the Somfy Tahoma, but it only has 2.7 out of 5 stars on Amazon with reviews mentioning concerns similar to the MyLink system. That concerns me.

Has anyone found a good and reliable way for HA to control Somfy RTS? I need something reliable. Our Phantom screens were expensive and need to be raised if wind gusts are over 25mph. I have a weather station integrated in HA, I need a reliable way for HA to raise the screens when gusts go over 25mph.

I prefer a local wifi or zigbee device, but I’ll consider anything.

The RFXtrxUSB-RFX433 RFXtrxUSB with RFX433 is able to control Somfy RTS (and a lot more)

Thanks, I ordered a RFX433. I’ll see if that works

About the same time you were looking for a solution I was too. I didn’t find anything that operated like I wanted so I built this. It may be what you are looking for and it is cheap and easy to do.

Thanks! Looks like a great contribution! I have the hardware ordered to make my own.

I have found it to be very reliable. It can be operated with WiFi or Ethernet and since it is all local you don’t need to worry about the storm cloud that everybody seemed to fall in love with.

Hey @rstrouse, you were helping me with issue #14 on your github. I’m happy to say that buying a new transceiver fixed my issue.

I am VERY IMPRESSED with this integration. This is by far the best way to control Somfy roller shades and should be considered the new standard with Home Assistant.

Well done!

1 Like

Thanks for the kudos and thanks for the antenna recommendation! While the little 2 inch duck antenna is impressive the 4 inch 3dbi antenna is shockingly good.

Hi, I’m new to home assistant but generally quite technical. I’ve been frustrated with Somfy’s terrible integration options and was excited to see this. I ordered that 433Mhz antenna+radio, but how do I install ESPSomfy-RTS? I can’t find it in the integration store. And I installed HACS and couldn’t find it there. Thanks!

You will find extensive documentation installation and configuration in this wiki.

If you are just looking for instructions on how to install the integration into HACS see the installation section in the integration repository.

@rstrouse, congratulations for your great contribution.
It is by far the best project I have seen in a long time.

I just installed it on an ESP32+CC1101+Home Assistant and it works great.

I think I have read all the documentation available and I am still wondering if it is possible to somehow integrate a wind sensor into HA so that it can trigger some automation.

Maybe it’s already solved and I’m the one who hasn’t been able to figure it out…

@emg I use a Tempest weather station to monitor the wind. If the wind gets too strong my ESPSomfy RTS puts up my patio screens.

Yes, that is an option that surely works. Thanks @bphillips921

However, I am referring to the Somfy wind sensor associated with a Somfy awning.

Just after asking the question I saw something I hadn’t noticed yet.
In Home Assistant, a wind sensor already appears for each awning:

I’m going to investigate this, because if I can understand how it works I will surely be able to use it in automations

You link wind sensors to the motor. The sensor states will show up in HA and will then retract the awning when there is a windy condition. The link below should take you to the section in the documentation for linking the sensor.

Thank you @rstrouse. I have followed instructions and have a rectangle/module called “ESPSomfy RTS” now showing in my HACS page’s “integrations” tab. I also got received my RFX433XL USB radio which I flashed to the latest ProXL1 firmware (as recommended) called “RFXtrx433XL_ProXL1-1048.hex” using the “RFXflash Programmer” tool from a windows machine. It is plugged in to my new x86 mini PC running HAOS.

I think I expected the device to be auto discovered by Home Assistant in the way it found all the devices on my home network and for it to show up in Settings > Integrations for me to configure. The only real sign of life I see is that in Settings > System > Hardware > All Hardware button, there is an entry called ttyUSB0 which is clearly the device. I’ll paste the info below (Note: I added “[TITLE]” several places to indicate the headers in the hardware dump.

I guess I’m wondering if I’m missing something obvious here. Is the only way to control my Somfy awnings to write python new code referencing Services wiki? Also, the red light on the radio is on constantly so I wonder if something went wrong with flashing it (though it seemed to work fine and shows up as ttyUSB0 as shown below. Any thoughts / guidance would be much appreciated. Thank you

[TITLE]Device path:
DEVNAME: /dev/ttyUSB0
DEVPATH: /devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2:1.0/ttyUSB0/tty/ttyUSB0
ID_BUS: usb
ID_MODEL: CP2102N_USB_to_UART_Bridge_Controller
ID_MODEL_ENC: CP2102N\x20USB\x20to\x20UART\x20Bridge\x20Controller
ID_PATH: pci-0000:00:14.0-usb-0:2:1.0
ID_PATH_TAG: pci-0000_00_14_0-usb-0_2_1_0
ID_PATH_WITH_USB_REVISION: pci-0000:00:14.0-usbv2-0:2:1.0
ID_SERIAL_SHORT: 406118a4e03fee118bb0b6329c2bee17
ID_TYPE: generic
ID_USB_MODEL: CP2102N_USB_to_UART_Bridge_Controller
ID_USB_MODEL_ENC: CP2102N\x20USB\x20to\x20UART\x20Bridge\x20Controller
ID_USB_SERIAL_SHORT: 406118a4e03fee118bb0b6329c2bee17
ID_USB_TYPE: generic
ID_USB_VENDOR: Silicon_Labs
ID_USB_VENDOR_ENC: Silicon\x20Labs
ID_VENDOR: Silicon_Labs
ID_VENDOR_ENC: Silicon\x20Labs
MAJOR: '188'
MINOR: '0'
TAGS: ':systemd:'
USEC_INITIALIZED: '12029683007'

You have to flash RFX433 firmware in the RFX433XL!!!
ProXL1 firmware can only be used in the older RFXtrx433XL.

Somfy RTS is not received by the RFX.
Pair the Somfy RTS motor using RFXmngr. (see the RFXtrx User Guide)
After this transmit a STOP/My command with RFXmngr. The hex string to be used in Home Assistant is displayed after “HA”

@defcongo RFXtrx433 is not needed or desired for the ESPSomfy RTS integration. There is no need for any other device. If you have ESPSomfy RTS installed in your HACS store, then it will automatically detect any ESPSomfy RTS devices on your network. However, please verify that you finished the install and “downloaded” the integration. There is no need to go through any other incarnations of capturing hex strings or editing yaml. It will just show up with all the entities controlled by the device.

Also, it should show up in HACS with an ESPSomfy RTS icon not a simple rectangle if you entered the url properly then downloaded the integration.


Thanks, all. I ordered a USB device (called “RFX433XL USB”) because that was what was linked above in this thread. (It is the “XL” model which is why I flashed the XL firmware). I have it plugged into the USB port of my mini PC running HAOS. Now I’m wondering if ordering it was a mistake and I should have ordered a device that is networked with Ethernet or Wi-Fi, such as this RFX433XL LAN Or perhaps I could add to the USB radio this which looks like a LAN adapter instead.

The only good part is that when I installed the integration called www[dot]home-assistant[dot]io/integrations/rfxtrx/ (sorry can’t have more than two links) from Settings > Integrations (not in HACS!) it let me choose serial interface ttyESP0 where my radio is plugged in.

Still it seems like I’m crossing two streams here: (1) the embedded path which might support USB serial connection and (2) the @rstrouse ESPSomfy RTS-HA HACS module which seems to always refer to the device being on the network (not USB). Because no device is automatically showing up in the overview. Do I have that right?

The more I look at this, I may be looking at it wrong. Before getting this USB radio, all I had was three Somfy awnings motors and a 433MHz remote control. I had tried using the Somfy MyLink device and it was complete (overpriced) garbage. So I was hoping these RFX devices from were an off the shelf way to solve the problem. Seems like I need to build my own hardware (which I can take on).

@bphillips921 and @b_weijenberg were you able to get it working with the USB hardware linked above from ?