Integration for NissanConnect Services

Hi, we just received our new Nissan Ariya and it seems to be using a new service Nissan have developed that’s different from the one the Leaf is using. Obviously I therefore can’t connect our car to Home Assistant with any existing integrations which is a shame.

The new app for the Ariya is called NissanConnect Services so if anyone out there have a Nissan Ariya and have the skills to develop an integration for Home Assistant that would be appreciated!


I have a nissan leaf and i also use nissanconnect but i can’t integrate it in home assistant.

Thanks for your reply. I’m kind of happy to see that I’m not the only one. Hopefully someone is able to create an integration for home assistant for this newer Nissan service.

Would also really love this as an integration. We just got our Ariya a couple of weeks ago (great car by the way), and would love to get it in Home Assistant :slightly_smiling_face:

Will follow along as I’m expecting my Ariya in March, I now have my current Volvo in HA, and would love to have the new car also in HA.
I’m not an integration developer or anything but if I can help with testing, or look at some code I’m interested.

Me too - Got new ARIYA a month ago and would love to get it in HA :slight_smile:

Mee to, have Ariya and nissanconnect

Not sure if this can somehow be used as a work around, until an integration is made, but it’s possible to connect NissanConnect to Google Assistant, so that battery level etc can be enquired through assistant. Though it doesn’t show as an entity in Google Home…

But following this, you can enquire things about your Ariya.

Is there anyway to get this from Google Home, over to Home Assistant? I’d really love to at least get an up to date battery level in home assistant, as I’ve already got automations for my Easee charger, which would benefit from knowing the cars battery level. Anyone know how this could be done?

First attempt was with leaf2mqtt which worked, but did not gave me battery % and running the docker in hass was making supervisor moan and complain… as i did not want to setup another docker instance somewhere I focused on node red.
Thanks to node red and the work of various people I finally start getting somewhere.

Thanks to following gits : GitHub - netmb/nodered-nissanconnect , which was no longer working due to changed urls and some methods, but because of the excellent work of Tobias Westergaard Kjeldsen / dartnissanconnect · GitLab i was able to refactor it to get working.

It’s a start

1 Like

Awesome news, great to see that you’ve made a start on this!

As a bit of a noob, and a non Node Red user, can you explain a bit more in basic terms, how I can get this up and running for mine?

some progress

I also figured out where to get the estimated range from, this is in a new v2 url on the API
Next thing on the to do is Lock/Unlock, but as the car is not at home, it is not wise for me to start locking or unlocking :slight_smile:

1 Like

Love it! Once you’re finished, I’m hoping you’ll make a guide for how the rest of us can implement this :slight_smile:

Yes, sure I will upload it to a GIT once I’m done and cleaned it up.
@celodnb but if you are a “noob” as you call it on node red I would first dive into this already first :slight_smile:

1 Like

Great, thanks very much! And I’ll look into getting Node Red up and running, and get to know the basics :slight_smile:

For who is interested, github with the flows and some information is shared
GitHub - kevinVl/NissanConnect-HomeAssistant.

@doberbert @celodnb

1 Like

Thanks so much for publishing this!

But I’m wondering if I’m a bit out of my depth with trying to implement this, as I can’t get it to work.

I have imported the flows into Node Red, and I can see under the logs in Node Red that I am connected to my MQTT broker. But when using the MQTT explorer, I cannot see leaf in the list of devices (I only have two other MQTT devices in our house, and these are shown no problem).

So I’m thinking there is something else I don’t have set up correctly.

I’ll be honest, I don’t use MQTT much at all (the two devices as mentioned above, which are just local devices, a Xiaomi blind motor and a ESP hacked Roomba vacuum), and it’s also the first time I’m using Node Red, so I assume there’s something I don’t have set up in either of those to allow me to get this working.

Any ideas what I might need to check?

So I am new to using Node Red, but I’m making a little progress, but still need some help.

I can now see a message has been sent, and that leaf is on my explorer list in MQTT explorer.


But it’s empty at the moment, so there’s obviously something very simple (beginner mistake) that I haven’t configured/done correctly.

Firstly, I added my credentials to the ‘Set flows-Vars-Config’ node, as mentioned in the github readme. I assume that I only need to change the username and password fields, near the end of the code? I assume these are also the credentials used for the Nissan connect app?

I’ve also configured my MQTT broker node as follows. Does this look correct?

I’ve tried just injecting on one of the nodes, but I receive the following errors.

Any help would be greatly appreciated, as I really want to get this working :slight_smile:


I’m exactly on the same level as you but I’m stuck too.

Looks like we need to wait for @kefjevl. Hopefully he can give us a more detailed guide :slight_smile:

Sorry guys, family emergency needed my attention.

It looks like you guys didn’t fill in your credentials correct and make sure you set it by executing the node by injecting the time stamp.