Integration of USB-RF selve Gateway to control blind / arwings motors

I’ve just bought a selve USB-RF gateway that allows me to integrate selve motors through a serial port.
The gateway handles all the rf communications and in order to “use” the gateway a very straighforward xml protocol through serial port is defined.

I’m knew to Home Assistant, and I would like to know Is there any way to define a serial switch?
I have found a serial sensor to listen to the serial port but not the other way of communication.

Thank you in advance,

1 Like

Hi Gabriel,
did you ever create a Selve integration for Home Assistant?
Or find something that acutally works?
Take care

Hello Frafro,
I have implemented my own Selve integration.:

I’m in the process of adapting it to the “new” configuration visual workflow.
However at this moment it can only integrate iveo devices. If I would have access to any commeo device for testing I could try to add that integration also .


1 Like

Hi Gabriel,
well, I do hva Commeo devices over here, but I am afraid I cannot just “throw them over to you”. :wink:
But if you have something to test I will be doing my very best to check it out.
Warm regards
PS: I am based in the “Ruhrgebiet” in Germany.

Hey guys, if i want to enter the port in Home Assistant Selve it tells me the port seems to be incorrect. But the port is definety correct as i requested it via. ls -la. Any help? Did i missed sth.?

I downlaoded all the git stuff and this is now also stored on Home Assistant. Selve Gatewy is also working on a windows device.


Searching for a method how to manage my SELVE IVEOs from Home Assistant for several months I found your SELVE integration. I bought the SELVE RF-USB Stick and used it on a PC with the SELVE-software to connect my 6 SELVE IVEO devices to the stick. I could drive up/down all 6. Now the stick is running connected to the Raspi driving my Home Assistant.
BUT I never worked with scripts and python scripts in HA. It would be a great help for me, if someone could explain the steps I must do now to get to be able to drive the rollershutters via HA.
For my understanding HA per default is able to call python scripts.
Where can I find a complete Setup-description?

At first I downloaded the “python-selve” module from Github (version of 16.10.19) and copied it into the HA-folder config/python_scripts/python-selve-1.2.1
The download of “homeassistant-selve” module (version of 16.5.23 ) from Github into the HA-folder config/cusom_components/selve was the second step.
Third step: entry in configuration.yaml:

  - python-selve==1.2.1  
#  port: /dev/ttyUSB0
  port: /dev/serial/by-id/usb-FTDI_FT230X_Basic_UART_DK0G3D1U-if00-port0

Do I have to make changes regarding the port in any other file(s)?
Is there an additional setup process within HA to get devices / entities for the already to the stick connected IVEOs?

What must I do to drive the IVEO-rollershutter named kitchen up / down?
Define a button which calls a service to execute a python script to send the IVEO-command via the stick? Must I write my own python script using the commands of the selve library first for this?

I found some hints but do not understand to realize it:

Create a new instance of the gateway:
gat = Gateway(portname)
portname is the name of the serial port where the usb rf gateway is listed on the os. Please refer to the serial library documentation.
By default the gateway will discover all Iveo devices already registered onto the gateway.
To access them:
Will return a list of IveoDevices()
Each IveoDevice can be controlled by using the already defined commands: stop() moveUp() …

I would be very glad if there would be anyone to help me to get the IVEOs running!

Have a nice evening.


Yo don’t need to install it as a python script it is a custom component.
Just copy it to the config/custom_component folder (I will provide a HACS compability soon) and after reboot configure it adding the selve integration from the devices/integration menu.
If you already have the blinds teached in the stick it should find them and you will be able to use them.

Let me know if It worked or if you need more help.

1 Like

Hello and thank you for your answer!!!

I deleted the old selve- and python-selve directories in custom-components and python-scripts, downloaded selve again from github and moved it via samba to HA.
Entry in configuration.yaml exists:
port: /dev/ttyUSB0

Then i restarted the Raspberry Pi and got the following error messages


When I tried to do configure it adding the selve integration from the devices/integration menu, I get this message:

I tried to validate the configuration:

Must library python-selve exist on HA-installation?

Oh - missing snapshots:

ok - i have no possibility to send more than on snapshot in a message and not more than 3 comments to a thread becaus e my new user status …


The readme is not updated as this component should be added using workflow instead of adding it to the configuration.yaml.
Try the following:

  1. remove the configuration yaml part.
  2. Go to HA->settings-> devices & services → add integration button.
  3. Selve integration should appear listed, add it and fill the form. It may take a while as the python dependencies are being downloaded.

If everything is properly configured your devices should appear in HA.

Let me know if it worked.

1 Like

Hi Gabriel, thanks to admin support I now can answer again …
I yesterday also posted here:

I think there are 1 or 2 unsolved minor points in my setup:

  1. since yesterday HA lost the contact to selve devices for unknown reason 3 times: after reboot or ofter repeat the setup options from …-menue of the selve-integration they appeared again.
  2. when I drive the shutters more than on shutter moves - perhaps I did a mistake when I teached the connection to the usb stick on the pc: possibly I had more than one RF-motor selected to learn in to one channel. I will repeat the complete procedure soon …
    But all together can automatically be opened and closed - that is really wonderful!!!
    Thank you very much again!
    Greeting … Peter

and another problem I just could solve: USB-RF stick after some reboots seems to have changed its port, so zigbee2mqtt did not start anymore. After changing config in addons → zigbee2mqtt it could be started again. Perhaps that could have been the reason for loosing connection to sleve shutters?


Also very new to this and trying to get the Selve USB-RF work. I have the Selve integration working, however it doesn’t find any device/entity.
The USB-RF shows a green light and when I use my existing remotes for the Commeo components I’m trying to get to work, the USB does show a brief yellow light every time I press a button (shutter up/down). So that tells me the USB recognizes the signal, so why doesn’t the HA Selve Integration show any devices or entities?

I’ve installed the package per above, even removed and reinstalled, moved the USB to another port, all with the same behaviour and same results.
I’m puzzled, anybody any idea?


Anybody please?
No clue how to program the shutters into the USB-RF.


First program the USB-RF in my case i use a Windows PC for it you can download the config software at the site.

and I probably need to install SW in the Windows PC. Thing is I don’t have ANY windows access except my work laptop which is as you’d guess blocked from installing anything.
Other thoughts?

Hallo rai-rob, can you tell me how you program the USB stick in Windows? With me it didn’t follow the channels, I created 3 channels for 3 shutters, but they all 3 go open… Thessa