Integration Solar inverter huawei 2000L

I faced this error when trying to install this integration I am using HA 2022.3.6
image

Thanks BM Kortrijk for your reply …
as soon as I can connect I will follow what you advised me …

Thanks wlcrs

Thanks for the tip, now I try and see what I can do …

i can’t connect to the inverter now … not even on port 6607, i’m trying to disable modbus but i can’t find the location

thanks for the integration. I think I used port 6607 but don’t remember the slave id. How can I check which port and slave id is being used?
finally after trying for 5 long days got my inverter back onto HA

Port 6607 will only be available on 192.168.200.1 of inverters with recent firmware. Make sure that you’re able to ping 192.168.200.1 from your HA before attempting to setup the integration.

I use the wireless radio of my OpenWRT router to create a bridge between my home network and the inverter SUN-XXXXXXXX wireless AP.

Below you can find the relevant parts of some config files to achieve this:

/etc/config/network:

config interface 'wlan'
        option proto 'dhcp'
        option defaultroute '0'

Note that failing to set ‘defaultroute’ to 0 will result in loss of internet connectivity as the OpenWRT router will try to route all internet traffic over the inverter instead of your ISP!

/etc/config/wireless:

config wifi-iface 'wifinet0'
        option key 'Changeme'
        option ssid 'SUN2000-HV0123456789'
        option device 'radio0'
        option mode 'sta'
        option bssid '94:25:33:12:34:56'
        option encryption 'psk2'
        option network 'wlan'

I’ve put the inverter into it’s own firewall zone sun, and allow all traffic between lan and sun. This could probably be improved to only allow Modbus-traffic, but I haven’t figured this out yet.

/etc/config/firewall:

config zone
        option input 'ACCEPT'
        option name 'sun'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option masq '1'
        option network 'wlan'

config forwarding
        option dest 'sun'
        option src 'lan'

config forwarding
        option dest 'lan'
        option src 'sun'
1 Like

Port 6607 is only available on IP 192.168.200.1 on the inverter AP. Slave ID is set by the installer, so I have no useful hints apart from: it’s between 0 and 128 (bounds included).

here are some useful screenshots which might help I think. So slave ID must be 1?




My dongle ip is 192.168.18.229, I have followed the steps as shown in the readme and confirmed by the above screenshots. so Should I use 192.168.18.229 as my host IP and port as 6607 to connect via the dongle method?

Please thoroughly read the first section of this wiki page: Connecting to the inverter ¡ wlcrs/huawei_solar Wiki ¡ GitHub . It does not mention port 6607 on anything else than 192.168.200.1, which means that that combination does not exist.

I was referring to the dongle method (option B) of communication.


Previously I am using a WLAN bridge using fresh tomato running on Asus 86U but since it is placed far from the inverter signal are weak. On the other hand dongle itself it being connected to the my ISP router without any issue so I thnk it is more stable connection.

Thanks wlcrs for your time …

The strange thing is that immediately I was able to ping the address 192.168.200.1 now not anymore and I don’t understand why …

Hi, I have started using the wlcrs integration. I was using the other integration and I calculed the energy used by my home for using it in a Grafana chart with this sensor template:

energy_used:
friendly_name: "Total energy used"
unit_of_measurement: 'W'
value_template: >
    {{ '%0.2f' | format(state_attr('sensor.sun2000_4ktl_l1', 'input_power') | float - state_attr('sensor.sun2000_4ktl_l1', 'power_meter_active_power') | float) }}

But I could not find a sensor as “power_meter_active_power” with this integration.
Any hint?

Thanks in advance.

I have just found out. This is what is working for me:

  - platform: template
    sensors:
      energy_used:
        friendly_name: "EnergĂ­a consumida"
        unit_of_measurement: 'W'
        value_template: >
           {{ '%0.2f' | format(states('sensor.input_power') | float - states('sensor.active_power_2') | float) }}

Hello everybody

Guys a question, a small survey …

Based on your type of connection to the wi-fi inverter or cable, what frequency of data reading do you have?

FYI

Basic Data Set :

try this for power: GitHub - mrgadget/tesla-style-solar-power-card: Home assistant power card mimicking the one tesla provides for the powerwall app. (but you’ve create some additional sensors)

1 Like

Ok getting a bit tired of “Connection already in use” / “The device has been connected. Try again later” when connecting to the internat TCP MODBUS on the SUN2000-KTL4
If I get a Wifi or RJ45 Dongle will this problem go away? Do I need a dongle for every inverter? Or is it enought that the master Inverter has a dongle (After I connected a battery to the master inverter it seems that I no longer can talk directly to the slave inverter)

I turn of the system completely for 5 minutes the error still comes up.
Will there be a problem If I get the dongle and upgrade to the latest firmware ?

Ok getting a bit tired of “Connection already in use” / “The device has been connected. Try again later” when connecting to the internat TCP MODBUS on the SUN2000-KTL4
…
I turn of the system completely for 5 minutes the error still comes up.
Will there be a problem If I get the dongle and upgrade to the latest firmware ?

Starting from today I have the same problem and I found the port 6607 closed (also 502).
image
I switched off the whole system for 15 minutes but this not resolve.
In this condition also the app can’t access to “commissioning” menu so I can’t make analysis…
Have you found a working way to “reset” the “Connection already in use”?

@wlcrs Love your work :slight_smile: Running 0.5.1 right now.
Is there a way for your integration so lookup the slave? I can’t login to the inverters (they require firmware upgrade to login and thats a bad thing I have heard) to find the slave ID on my second inverter.

I now nothing about modbus but should it be in some register since after they attached my LUNA battery I can no longer connect to the second inverter since it’s a slave to the one with the battery.

Hi ligeza
A question…
the configuration that I kindly made available, I can ask you if it is still valid and which setting you used, like that of EmilV2 … or other
Also what firmware are you using for the inverter and dongle
And finally, what type of connection do you use wi-fi or Lan-wired and the ip address of the iinverter in use.

in practice I can ping the address 192.168.200.1 but I can’t connect with the “Huawei solar” integration, I use a lan-wired connection.

Thank you so much for your time