Integration with Daikin Skyfi app (Air conditioning)

Not sure if it helps, but I’ve finally updated my version on github.

Seems to be working reliably for me.

You may want to try reversing the order you run the commands, try the fan mode before the set temp

Yeah, not sure what is wonky with my setup, whenever I call something else than set temp, it reverts the temperature to 22 which is a bit annoying (e.g. if I just want to keep the current temperature and only change the fan speed).

I´m also having the same problem, whenever I change Operation Mode, Fan Mode or Swing Mode, the Target Temperature is always automatically set to 22º, I thought this was only a problem of my setup, but now I see this is a component integration problem, can you guys verify this and fix it?
I have been testing the Daikin Component for a couple of months and I can testify, to my knowledge, that this problem was not present in older versions.

1 Like

Just to confirm, Are you guys talking about the Daikin componet in the released HomeAssistant,

or the SkyFi component by myself and bircoe?

I con’t reproduce the issues you are talking about.

Yes kabongsteve I’m talking about the Daikin component for the European versions of the Daikin AC.
the version of all my Wifi adapters is BRP069A41 made, according to the box, in the Czech Republic.
Thanks for checking this out.

@DavRebelo, check out the discussion here about it resetting to 22*C.

Hi Steve, I really appreciate the work you’ve done on this, and I’ve installed it on HA in my place. I have a couple of questions however, and was wondering if you’ve had any issues similar to mine. The target temp on my HA is always set as 0 degrees, and I can’t figure out how to change it as default. When I select a mode in HA, It sometimes turns the Daikin Skyfi/AC on, but not to the mode I selected. It just reverts to the last mode the AC was in. Is this normal behaviour? Finally, the automatic Alexa integration that HA creates works for everything but the SkyFi, do you have any idea why?

As a side note, I noticed on Whirlpool that you said that you were frustrated with the android app (I am too, its terrible on my note tablet), but I also use the iOS app on my iphone, and it is faultless. The AC responds immediately, every time, and there are never any faults or miscommunications. It also has additional functionality like displaying the outside temp at the same time as the room temp.

Any help would be much appreciated, and I really appreciate all you’ve done so far, it’s the exact solution I’ve been looking for, and I feel with a few tweaks, I could get this thing working perfectly (alas, I’m a complete novice, it took me almost a week to get HA working).

Hi Tim, sorry you’re having so much trouble. I would suggest you run Packet Capture on your Android tablet and monitor the traffic between the ios app and the skyfi, and then the same between HA and the skyfi. Perhaps in monitoring that we can see what is going on and why the issues are occurring.


OK, Ill get onto that, I’ll report back in a few days with the results. (I’m not in my house right now, the bathroom is being renovated, so no water). I really appreciate your quick reply, also you shouldn’t be apologising for anything, right now you appear to be the foremost expert in Australia on Skyfi.

I have updated the version in my GitHub to improve reliability and issues found

1 Like

You’re a legend Steve. I haven’t had chance to run a packet capture yet, but fiddling around with settings has allowed me to fix most things. The only thing I’ve got to figure out now is Alexa integration.

Glad to hear.
I use the Google home integration, and once setup the link works. Slowly though. Haven’t t tried temp but in I’d worked
I’ve also now got HA controlling the temp and schedule, as my remote thermometer doesn’t register correctly. Working reasonably well so far. Next step the zones


Registered for the forums just to say thanks Steve. Nice work. Worked straight away for my BRP15A61.

mkdir .homeassistant/custom_components/climate -p
cd  .homeassistant/custom_components/climate

edit configuration.yaml
  - platform: skyfi
    host: 192.168.XX.XX
    password: XXXXX

restart service.


I got it working as well with the above configs. Well done Steve.
I really need to be able to control the zones as well though.
It would be great if this was possible.

How’s this intergration working? I’m looking at getting Aircon upstairs (in au) and wondering if we got the au model working correctly.

If you are looking for an alternative for Australia I choose to go with the Intesisbox product.

It has an integration already provided for Vera which I used to integrate with HA. The API is readily available so it would be possible to make a HA component for someone with the skill and time.

Note the intesishome is different but similar. It has an app but cost more to buy and has no published local API.

Intesisbox API

Intesisbox WiFi gateways

AU distributor of Intesisbox

1 Like

Thanks! I don’t have a Vera controller so might be getting very pricy to setup, how much are the controllers?

Looks like they might have one for my older AC units but I was thinking I need to go down the broadlink climate ir solution.

Anyone else with confirmed working Daikin AC in Australia? Please let me know what model unit you have

I’m in Australia, and it works fine with hass as per my above comment. I bought and fitted a BRP15A61 which worked with my Daikin. Pretty sure most Daikin units are supported by this controller.
I think I got mine from here:

I can’t however get full integration with Google Home for some reason. I enabled the google home bridge via the Home Assistant Cloud integration, and most stuff comes over fine into Google Home, but the aircon just shows the temp, and doesn’t allow any control. Like So;

Anyone got any tips on how to fix that? I would pay for Home Assistant Cloud if we can get this bit working.

1 Like

What password do I use when using one of the new Airbase controllers?

I don’t have one of them - the password I used was printed on my controller. I took a photo of it thankfully, so I don’t need to get back in the roof to read it! That would be deadly with the summer we are having.