Home Assistant Community

Introducing Hass.io Ingress

#1

Today we are proud to introduce a new feature for Hass.io called Ingress. Ingress allows Hass.io add-ons to seamlessly integrate their user interface with Home Assistant. Home Assistant will take care of the authentication and the secure connection, so users can start using the add-on directly, without any configuration necessary by the users. It just works. Even with Nabu Casa’s Home Assistant Cloud Remote UI!

Demo with an add-on on Ingress.

Add-ons that already support Ingress

Some add-ons already have been upgraded to support the new Ingress feature. Here are a couple of add-ons that support Ingress and are available on the add-on store right now:

Core add-ons:

Community add-ons:

You can recognize add-ons that support the Ingress feature by the Ingress icon on the add-on information tab:

Screenshot of an Add-on view with ingress support.

Please note, that in order to upgrade or install these Ingress enabled add-ons, you need to be running Home Assistant 0.91.3.

What’s next

Releasing the Ingress feature is just a start. It allows us to make even better integrations in the future. For the upcoming Home Assistant 0.92 release, we will be adding support to add links to your add-ons to the Home Assistant sidebar via a toggle on the add-on details page. The link will open the add-on Ingress interface, embedding the add-on in the Home Assistant UI. This will make it look and feel like a single system.

Other new things

While adding Ingress support, we have tweaked and polished some other things in the Hass.io user interface:

  • Network ports in the add-on view now have a description, so you know what they are being used for.
  • Reloading the add-on store will now show a spinner to indicate that reloading is being done.

For add-on developers

Ingress is added as an additional feature that add-on authors can choose to support starting today, granted that the application in the add-on supports it. The old approach of exposing add-ons on different ports will remain available. It will be up to add-on authors to choose what to support, including an option to support both.

If an add-on is going to support both, you should not have the add-on exposed on a port enabled by default. Instead, allow users to enable the port access by assigning a port number in the “Network” section of the add-on configuration panel.

Are you an add-on developer looking to support Ingress on your add-on? Check the developer documentation.

FAQ & Known Issues

Hass.io Ingress is a new and complex technology. Without a doubt, now that everybody starts using it, we will discover new issues. Here are some frequently asked questions and some currently known issues with the Ingress feature.

  • After upgrading the add-on, I’m unable to access it directly. Direct access to the add-on might now be disabled by default by the add-on developer. If the add-on supports running Ingress + direct access, you can re-enable direct access by setting a port number in the “Network” section of the add-on configuration.

  • After upgrading the add-on, my panel_iframe doesn’t work anymore. This is related to the question above. Once you enable direct access again, your iFrame panel will start working again. Until the automated panel integration lands in 0.92, you can also manually add a panel that points at Ingress.

  • I cannot upgrade my add-on: “This update is no longer compatible with your system.” Please update your Home Assistant installation to 0.91.3 or higher.

  • I cannot access the add-on via Ingress using the Tor Browser or Firefox. We found a last minute issue impacting Firefox based browsers (including the Tor Browser). There are some issues accessing add-ons that use WebSockets. We have identified the issue and expect it to be solved with the release of Home Assistant 0.91.4.


This is a companion discussion topic for the original entry at https://www.home-assistant.io/blog/2019/04/15/hassio-ingress/
9 Likes

#2

Awesome - just what I need when travelling and forgot to open up ports to access hassio addons.

So I upgraded to latest versions and tried ingress with latest ssh & terminal community addon and I’m getting “502: Bad Gateway” when accessing https://<myurl-duckns.org>:8123/hassio/ingress/a0d7b954_ssh

Any idea what can cause that ?

0 Likes

#3

Same Issue here.

0 Likes

#4

Is there a way to downgrade a specific plugin? I upgraded my Node Red but I already had that mapped to a subdomain url and can no longer access via that. Now I only have my ingress view and I lose a bunch of screen real estate to a tab bar that I can’t dismiss :frowning:

0 Likes

#5

Portainer is also using ingress, but in the config, you can specify the port, so it’s back to classic mode… Maybe you can do that in nodered too

0 Likes

#6

@Tecnico1931 Are you both using firefox? When I switch to that I get the 502 Bad Gateway in the addon logs.

0 Likes

#7

I stumbled across this yesterday before reading this blog post. I decided to give InfluxDB a go again after some time apart, but ran into a new problem.
After accessing the InfluxDB web UI through ingress, I created the ‘home_assistant database’ and the ‘homeassistant’ user, but I’m unable tho change the access rights for the latter, or for any of the other predefined users, for that matter. Does anyone know if this is related?
I also tried to enable the normal, non-ingress web UI port, but this doesn’t seem to work.
I can’t remember this being a problem on previous versions of InfluxDB, even on the same installation of Hass.io.

0 Likes

#8

Same for me: 502: Bad Gateway (using Chrome)

In hass logs: [hassio.api.ingress] Ingress error: Cannot connect to host 172.30.32.1:62239 ssl:None [Connection refused]

Few lines above i have:
[hassio.api] Start API on 172.30.32.2

So the question is shouldn’t Ingress use 172.30.32.2 ?

0 Likes

#9

I’ve been wanting this for years. Thanks!

Edit: node red and portainer working fine for me on chrome.

0 Likes

#10

Just updated to 0.91.3 and then updated the “SSH & Web Terminal” addon to 5.0.0 but I get the error “502: Bad Gateway” using Chrome.

I’ve already cleared the cache of the browser.

Any suggestion?

In the meantime I will revert back to previous version of the addon that is necessary to me.

0 Likes

#11

There is no sandwich menu button in the addon - How can I collapse the Homeassistant side menu?

1 Like

#12

It doesn’t have one right now.

0 Likes

#13

Did you specify ports in Network and enable the settings in the config options?

0 Likes

#14

Bad gateway mean that the Add-on is not running or they need long to startup and is not ready to provide the UI. More details should be available inside log

0 Likes

#15

I had that issue with the Hassio addon. I then realized the add on was still starting up. I watched the log until it was fully started and it worked.

0 Likes

#16

no, using chrome.

I figured out what was the cause - ssh terminal 5.0 is not backwards compatible with port settings (https://github.com/hassio-addons/addon-ssh/issues/71)

Thus if you like me have both the default ssh and this ssh running but on different ports then things fail as when updating ssh/terminal falls back to port 22 which is not available.

0 Likes

#17

The same for me - it took a while for addons to start.
Right now everything works fine (no more 502).

0 Likes

#18

I don’t understand… I have the ssh port in network settings set to port 622 and it works fine… what am I missing?

0 Likes

#19

When updating to v5.0 it sets the config back to port 22. You need to set it again.

0 Likes

#20

I thought feature were only added on major release versions. I thought the last “dot” was reserved for patches, not new features.

0 Likes