Home Assistant Community

Ios app and nabu casa remote ui

#1

Does anyone try connect with new remote ui nabu casa url.
On safari everything work ok.
In app i have Shared.TokenManager.TokenError error 1
I try reset app and uninstall and install again.

#2

It works for me. I just had to remove / in the end, it came along when I copied the URL

#3

Did you get this working? I’m having the same issue - connects fine through Safari but not the HA app.

#4

Got the same, any solution yet?

#5

Mine works in Safari so I just made a shortcut to the home screen for now. Honestly it looks the same in Safari as it did in the HA app. I tried typing the address and pasting it in to the HA app and could not get it to work either way.

#6

Hello, I have the same issue. The remote link works from Safari, but not from the HA app. Is there any solution?

#7

hi,

I was getting the same error, but it got solved when i upgraded to app to the beta version 1.5.1.

It appears ver1.5.0 from the appstore keeps throwing that error

#8

2.0 beta is now available. It is working.

#9

On 2.0 i have same error.

#10

What should the http settings be in configuration.yaml for this? I’ve been using my own domain (not dynamic DNS as work now block dynamic DNS domains for security reasons) and lets encrypt. I took out the references to those SSL certificates and changed base_url to my nabu casa link and left the server port in, but I’m getting the same error as everyone else. Can we leave out the base url and server port now if we’re using the remote UI?

#11

I am having the same issue. Unable to connect with Nabu Casa url in IOS app (both original and beta).

#12

I have the same error on my wife’s phone. My phone works just fine.

#13

Same issue here. Does anyone have a solution?

#14

Something I realized I was doing wrong was leaving the /Lovelace/… On the URL. You should remove everything after .naba.casa on your link. That solved it for me but you may be having a different issue…

#15

the nabu casa url I’m entering into the iOS app is:
https://reallylongseriesofnumbersandletters.ui.nabu.casa

#16

Don’t enter the ui.nabu.casa URL in the app. It automatically detects and uses it. This system has been improved in build 44.

#17

Mine doesn’t. I’m on build 44.

App 1.5 works great but no remote connection on beta 44. All three ticks are present.

It was working prior to the 43 update.

Is there anything I should be checking in my HA instance?

#18

I’m on .46 and it doesn’t appear to be working either. I don’t have a base url set in my HA config, I reset the beta app and connected automatically using my wifi. In the app it lists connected as Remote UI and the external URL is my internal IP (is that right?), but if I disconnect my wifi the app doesn’t connect.

#19

My suggestion to everyone is: wait. The next build has entirely reworked connection logic which makes the whole remote UI vs internal vs external issue much clearer and should fix all issues.

#20

No problem, thanks Robbie, will do