iOS Dark and Light Mode with easy background change - A theme pack

@NdR same issue here. With and without background and custom-header configs, set via profile. Only happens on iOS using the HA app and Safari. Seems OK on desktop browser

Edit: also created automation to set theme on HA start… same issue

Yeah, I confirm that I have this issue only from mobile, iOS App.

Ok i tested out a different background image and the flickering is gone so I’m going to play around with the background images provided and see.

Edit: @basnijholt I moved the file to /local/www/, reset frontend cache and restarted HA for good measure and all flickering is gone

Jake, could you explain me what exactly did you do? Thanks!

Copied the background for selected theme to /www/ and then updated the background-image path in the theme yaml file to reflect new location

@ludeeus, do you have any idea why this would solve the issue reported by @NdR here?

I don’t understand how this would make a difference.

1 Like

When served from www/* it’s cached.

Is there a way to make a HACS installed theme files to do the same?

Definitely, add a feature request so I don’t forget :wink:

1 Like

Thanks for the quick replies! I’ve opened this issue.

1 Like

Thank you m8. And I confirm that I solved it too, moving the files to www

Edit: this problem is fixed in HACS 1.5.2.

For others, experiencing the same problem, you can fix the caching problem (which causes white flashes on tab switches, by executing the following commands in the terminal:

mkdir -p /config/www/themes/ios-themes
cp -r /config/themes/ios-themes/* /config/www/themes/ios-themes/
sed -i 's/hacsfiles/local/g' /config/themes/ios-themes/ios-themes.yaml

This problem is also reported in the repo

Fixed in HACS 1.5.2.

I can’t for the life of me get the automation for selecting themes working. This is a brand new install. If I select the theme from my profile, it works. Backend does not.

From log:
[homeassistant.components.frontend] Theme ios-dark-mode-dark-green-alternative not found

Just confirming, can you select ios-dark-mode-dark-green-alternative in the profile tab?

No, only ios-dark-mode, default, or backend-selected.

The following is correctly placed in the configuration.yaml
themes: !include_dir_merge_named themes

I believe i found my issue. Wrong repository for wrong directions.

Great! That’s what I expected :sweat_smile:

Having a small issue with transparency - is there a way to easily make it more opaque?

I find it very difficult to read the menu’s whilst still seeing the text beneath so clearly.


Hi, First thanks for really nice themes!

I am getting this error what am I doing wrong ?


It might be that below is not placed in the correct .yaml file

- blue-red
- dark-blue
- dark-green
- light-blue
- light-green
- orange
- red
icon: mdi:format-color-fill

name: Dark mode
icon: mdi:theme-light-dark
name: Theme alternative (disable active state color)

Best regards,

1 Like