iOS device detection not working


#1

My iPhone does not appear in my Hass.io installation. I’ve added ios: and tried the regular as well as the beta App from the app-store. I also changed the name from my device to make sure it contains no spaces.
What else could I try?


#2

adding homekit component solves this


#3

Do you have discovery enabled?

If so, try leaving your phone on the iOS app startup/settings screen when you restart HA.


#4

I have added this to my config file without an effect. :frowning:


#5

Discovery is enabled, leaving my phone on the iOS app startup/settings screen while rebooting was not working. (Same is true for my iPad)


#6

Any other thoughts? I’m running out of ideas. I’ve restarted, added and removed ios:. I also had a look into the logs, but could not identify any issues…


#7

Do you have an “.ios.conf” file in your /config folder?

Is so, rename it “.ios.conf.bak” and try discovery again.


#8

No, I don’t have a file “.ios.conf” in my /config folder. Also manually creating does also not help.
I followed all steps you’ve suggested in this thread. I see this behavior on 2 iOS devices, hence I guess it has something to do with my hassio installation. It looks like something prevents the creation of the “.ios.conf”-file.


#9

Further hints:
I’m getting an 405-error if I’m trying to push my current location. (iOS App 1.5.0 32; hassio 0.84.2)
I’m on HassOS 1.13 and running the installation behind an NGINX Home Assistant SSL proxy. (valid SSL)


#10

I’ve updated system and app today, but still facing the same issue. Anything more I can do?


#11

No one who can help me to debug this behavior?:sob:


#12

I had exactly the same problem and found another thread with a solution that worked for me (adding api_password in the http section of configuration.yaml) plus ios:. With luck, we same fix might work for you. The link is:


#13

The latest version of the app does not use legacy authentication so that fix is no longer valid.


#14

+1 for getting this when pushing location:

This is with latest version (0.86.2).
In the HA log there is nothing.

I tried to configure the ios app to not use legacy authentication, but it always switches it back on.
Also if I remove the legacy api_password in config yaml then it seems the app cannot even detect the ios component and hence disables device tracker etc anyway… :frowning:

IMO What HA urgently needs is a user management UI which allows linking multiple devices from multiple trackers to a given user, and then tracking that user for occupancy and zones. The current approach with known_devices yaml is quite cumbersome.


#15

The latest version of the app does not use legacy authentication

It seems the latest version uses the new auth for the UI login - i.e. to display the HTML UI, but it needs the legacy API to support the IOS component.


#16

Because I’m curious: Does Hassio create a ios.conf file?


#17

TBH not sure. I upgraded to hassio ~1 yr back, but maybe the ios conf predated that and never got cleaned up…


#18

Also I think possibly this thread should be under the IOS category. Seems like it could be a bug in the hass/ios app infrastructure and maybe the app author (@robbiet480) can help us if its in the correct category?


#19

I‘ve moved the thread to the iOS category as suggested by you.


#20

Hi Folks.

Still seeing this 405 error whenever I try and push location from ios app to HA(ssio).
Is anyone else seeing it? Is it a known defect for ios?