IOS notification not working in IOS 13

Tags: #<Tag:0x00007f739bbbc810>

I recently updated my phone so made some changes to HA to point to the new device. I am not able to setup notifications to my new phone. Looks like there is a new process which I followed in - https://companion.home-assistant.io/en/getting_started/ I have loaded the app on my phone and performed all steps yet I am not getting the notify.mobile_app_ service coming up at all. I have allowed permissions on my iphone for the ha app to have location…etc. My configuration.yaml contains mobile_app and ios

Can anyone point me to what else I should be looking at ?

You need to restart HA again after setting up the app to get the notify.mobile_app service to show up. Try restarting one or two more times to see if it shows up.

I have restarted HA many times with no luck. I dont know where else to look.

I initially renamed the .ios.conf file to .ios.conf.bak file as its from the older config and when I remove the bak and bring that file back the service comes up, the only problem is that its still pointing to my old phone and now my new one. I could easily modify the file but the only problem is that I see references like “permanentID” or “pushId” which I dont have from my new phone.

The new HA Companion App for iOS does not use the .ios.conf file. You can delete that file as HA and the app will no longer use it. Does the app otherwise work and load your HA frontend?

Yes it loads the front end and able to navigate through the app as previously did but just cant get that notify service to come up in order to be able to use notification to my iphone.

Not sure if this makes a difference or not but I am also using hassbian

did you allow the app to use notifications (not the exact name, please check to be sure) during the startup of the app for the first time. As noted elsewhere, people easily can miss that necessary step… If not, delete the app, and reinstall. Check each service individually with the button on the right side of the screen. They all need the checkmark

  • Please give permissions to the app.
  • Watch the app set up its integration etc.
  • Once onboarding is complete, restart Home Assistant, then once Home Assistant is back online, force-close the app and reopen. This step is necessary so the notify service can register.

also, be sure to update your push_id settings in the app settings

Yes all that was done, i granted the correct permissions required but I still dont get push _id in my mobile app.

Issue is now solved. The main reason I was not getting the push id and I say this because I tried everything else must have been my pihole. The second I disabled it to perform the reset of the app and perform the same steps i have done many times now unsuccessful it ended up working. Push ID was registered. Now to feed my curiosity does the system need to reach out somewhere to perform any sort of check in which pihole would have blocked or was this just a red herring

Any number of Apple Services servers that administer Push ID registration could have been blocked by PiHole. I couldn’t give you a list, but go digging through your logs in PiHole and look for any blocked apple servers.

thx @stylesx I had the same problem with pihole

Has anyone noticed if this is happening after they use Personal Hotspot? I noticed issues with my home and away notices not working when I have the hotspot on in the car for the kids’ tablets. If I travel by myself all works fine. Rebooting my phone set it back from 2500 to 65.

I’ve got a similar problem with my iOS device also running V13.X
I had duplicate entries for my device, which I removed and have recreated my device, reset caches, allowed app notifications at the time of installing the app. I’ve updated my automations, scripts, etc.
Front end of the app works fine (on WiFi), I don’t allow remote access.
Unable to receive notifications on my device. Other notifications on other devices is okay.
Seems it’s just me…
Not sure what else I can try. A bigger hammer anyone?

Apologies - I probably should have this question in a different place. It’s kinda related, but not…
However… trawling through my log file, I see this:

Logger: homeassistant.components.mobile_app.notify
Source: components/mobile_app/notify.py:153
Integration: Mobile App (documentation, issues)
First occurred: 9:36:25 AM (5 occurrences)
Last logged: 10:17:16 AM

Requested entity was not found.
My mobile changes entity_id each time I reset its app settings.

Log Details (ERROR)

Logger: homeassistant.components.ios.notify
Source: components/ios/notify.py:103
Integration: Home Assistant iOS (documentation, issues)
First occurred: 9:36:21 AM (3 occurrences)
Last logged: 10:15:41 AM

Endpoint is disabled

I can’t find where the heck to check for disabled endpoints…

Last post on this.
I’ve deleted all instances of my iPhone I could find, reinstated the integration for my phone one last time.
Removed the App from my device, logged in again, notifications allowed… And it’s working again.
Odd.

Thanks to anyone who may have started to think about and perhaps respond to my problem.

This community is awesome!

I noticed today that notifications to my iPhone stopped working, while my wife’s worked fine.
Both on the same iOS version and app version.

When I tried to call the notify service from the dev tools, my phone never got the notifications either but the error count in the app settings > notifications went up by one every time I tried.

Then I went into my Pi-hole and disabled it, and re-enabled it and then it started working again.

What’s weird is that my wife’s worked fine even before I disabled Pi-hole… on the same Wi-fi of course. Weird.

1 Like

Mine’s broken again… Just mine though.
Weird.
Still trying to figure out what’s gone wrong and how to get it back.
sigh

1 Like

same here no fix anyone ?

I deleted ios.conf . Reinstalled etc

First check to see if the notify service exists, then Restart HA. The only issue I had was after I reset the notifier ID, I had to restart HA so it knew of the new notification ID and then the service showed up and notifications worked.