Home Assistant Community

iOS v 2.0.0 (40)

#1

On the new version - somehow my device id got messed up…

on the app’s settings it still have chris_iphone_x which is correct but now in HA, it shows it as:

I still have the old entity but it’s not updating:

0 Likes

#2

Use the new one, you will get a new ID every time you set the app up again. So if you were to reinstall the app it will give you a new ID.

The old one will no longer work.

0 Likes

#3

I hear ya but that doesn’t really say why versions (36, 37, 38 and 39) were fine and it just suddenly changed.

0 Likes

#4

It is because RobbieT converted everything to a new component. Whereas the old versions still worked with the ios component. The app now uses mobile_app component instead of the old ios one.

Don’t ask why he converted all, but to my knowledge this is more secure and this way he doesn’t need to update the ios component individually. He can just update the app as it relies on mobile_app (which in turn can be used by other apps as well).

0 Likes

#5

oh yeah, I remember reading that. I guess since we can’t edit the device trackers id, we wont be able to tie it in with icloud3.

It seems it broke ios messages, i will look into that.

0 Likes

#6

Ios notifications? Or actionable notifications? They both should work. Just open the actionable ones in the app (the new way) you don’t need to do anything else just land on the page once. They should work again.

If you are talking about standard notifications, the ios component will be phased out as far as I know and it will use the new mobile_app component.

Open dev-tools and go to services. Find the following service: notify.mobile_app_PHONENAMEHERE, this will be the new way of notifying. Works fine here.

0 Likes

#7

Yea I read about the mobile_app… It just doesn’t work.

I have had this mobile_app id from version 38 i think…

Output from node red after “successful” message even though I dont get it on device.

{
    "_msgid":"c34949be.64a6c8",
    "topic":"",
    "payload":{
            "domain":"notify",
            "service":"mobile_app_chris_iphone",
            "data":{
                "title":"Home Status",
                "message":"Performing Good Night",
                "data":{
                    "push":{
                        "thread-id":"Home Actions",    
                        "sound":"US-EN-Morgan-Freeman-Good-Night.wav"
                    }
                }
            }
        }
}

it’s all very odd… I’ve restarted HA and node-red multiple times… that is the only mobile_app entry available… :man_shrugging:

0 Likes

#8

Hm, I have to admit that I have reset the app/HA configs etc. After installing version 40.

It gave me completely new device tracker ID’s. But the same mobile_app ID’s. Did you try with dev-tools to send a message (meaning take node red out of the equasion). If it works it is maybe a node red problem (though I have never touched node red so I can’t comment on that).

Restart the app, reinstall it, restart HA several times with the app open etc. It might help, or might not at all. More people have these problems though so I am guessing that Robbie is working on it.

0 Likes

#9

Yeah it’s so weird…

I tried on dev, hit Call Service and it did nothing… checked the console:

Internal server error, please try again later: That is not a valid FCM token

lol… i will wait until next version :slight_smile:

0 Likes

#10

Ensure that you see a push ID (a long string) in the app’s Notification Settings. Force restart the app once or twice until you do. Once you do, hit the up arrow in the web view to update the token to your HA. Things will start working then.

0 Likes

#11

i have done that a few times too :frowning:

0 Likes

#12

So do you have a push ID showing in the app?

0 Likes

#13

Hi,
I do also have this new deviceID in my Setup after installing the beta.

Thank you for making this possible. I do like the upcoming features like Siri control and stuff.

I do also run die legacy app as well so I got nearly two identical devices tracked with two non equal IDs.

Is there anything else that comes with the beta app, which is not contributed on the Legacy App?

Do you think it will interference the current setup, when having legacy and beta app installed?

Im new into the world off HA, so don’t be so harsh with me :slight_smile:
…if I did not found this topic I would still guess I messed up the deviceID of my iPhone myself.

Thank you in advance and enjoy your day.
(…starting off right here)

0 Likes

#15

This is what I have…

iOS app:

iOS ID:

HA:

Does it get it’s name from the iPhone itself and not the device id?

That name still doesnt get any messages…

EDIT:

this is the error from sending the nofity command:
image

image

0 Likes

#16

Just another FYI…

I did manage to fix this… On the intergrations screen I had 3 Entries for mobile_app_chris_iphone…

I deleted all 3. Restarted HA… opened iOS app, and did a reset… Closed and opened the app 2 more times and redid all my info. after i signed into HA on iOS app, i forced a location update and then I restarted HA again. After that, all was well.

0 Likes