iPhone app no longer works

HA use to show up here.

Yes it does.
Still there

I am on an Apple but it’s the same thing

Ok, so everything I said about proxies and such shouldn’t matter if you’re using nabucasa (at least I think, I don’t use it).

Samba allows you to access the folders like I said above. From what I can tell, that seems to still be working.

When you connect to HA, what URL are you using on your laptop?

Hello Petro,

I can see the files from File editor but not sure how to show hidden files.

You may have to actually manually type the location in windows. Windows is not smart sometimes.



in an open explorer window.

On windows to view hidden files:

The IP address is

Not sure how to reveal the hidden files either.

One more thing. This is my current setting for the cloud. Is that potentially interfering?

Or it has nothing to do with it. Never gave issues …

I reinstalled the app again. Then I get a one-off access. So at least I can go in and change things.

You said you’re having issues with the phone apps, right? You also said you’re connected on your laptop? So, on your laptop, what is the full URL that you are using to connect to HA? Its located at the top of your browser.

Hi Petro, Still no luck my ODROID-N2. From a blank Explorer window I’m entering but get nothing…

are you using the double \?


Worked in the past. Now I get the
Logo with a retry:

No I wasn’t… I now see the HA files. Thanks Petro

1 Like

You should have the option to configure it or at least access the sidebar to view whats being used in the ap. Also, make sure you are connected to your wifi for internal access to kick in. When connected to your wifi, the app will use your internal url. When you are not connected to your wifi, the app will use your external URL.

So, what to do:

Turn on wifi and see if it connects. If no…

Turn off wifi and see if it connects. If no…

Uninstall and reinstall the app and go through the ‘app configuration process’.

Make sure your internal url is set to when setting up the app. Make sure you are on wifi during this process.

Ok. Progress report.

Under general configuration I disabled Remote UI

In the app config I put the IP address as stated both on the internal and external url.

With WiFi on the app is back and works fast. Incl refresh.
Without WiFi nada.

This makes sense So far so good.

Partly happy now. But the laptop still the same story.

And I don’t know what will happen if I connect nabu and remote ui.

Yeah, the app tries to be smart and switch based on what SSID (name of your wifi network) you’re connected to. For example, if you’re connected to your home wifi network named IHATERAIN, the app will try to connect using the internal IP. If you’re connected to any other SSID (or not connected to WIFI), then it will use external.

But why is my laptop not connecting ?

You said it was before… so now your laptop is not?

It was but at some stage both failed

So my laptop is still off but I can see HA files via the network

So my app works with the local network. No issues but there is something off the the Remote UI. I don’t know what but that’s step3. Step 2 is getting it back on the laptop.

I first will restart HA to confirm the settings.

Bad decision. App is down again. HA close to
the bin now… :triumph:

So we are 8 or so hours further and back to square 1…

If you clear the cache, does it then suddenly work? I ask, because I might have the same issue since yesterday on all devices, both outside my network as inside (using DuckDNS). Clearing cache works temporarily. Driving me insane though to clear cache multiple times a day per device…

No. Make it’s worse. Anything from a refresh, restart and reboot sets me back.

I am done with this. Home Automation is meant to make life easier not more complicated and frustrating. Switching on the light when you come home by clicking a real switch wins by far…