iRobot Roomba Integration no longer working after Update to HA 2024.2.3

Does anyone else has this Issue?
iRobot Roomba HA Integration is no longer working since update to HA 2024.2.3, Robot get discovered as new device but cannot be added (was working fine before).

Even the workaround (GitHub - koalazak/dorita980: Unofficial iRobot Roomba and Braava (i7/i7+, 980, 960, 900, e5, 690, 675, m6, etc) node.js library (SDK) to control your robot)) is no longer working -

1 Like

I am having issues with the Roomba update after updating HA Core to 2024.2.3

I enabled debug & reloaded the integrations finding the follow errors in logs:

2024-02-25 17:45:41.985 ERROR (MainThread) [homeassistant.config_entries] Error setting up entry Matt for roomba
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/config_entries.py”, line 444, in async_setup
result = await component.async_setup_entry(hass, self)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/src/homeassistant/homeassistant/components/roomba/init.py”, line 40, in async_setup_entry
roomba = await hass.async_add_executor_job(
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/local/lib/python3.12/concurrent/futures/thread.py”, line 58, in run
result = self.fn(*self.args, **self.kwargs)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/local/lib/python3.12/site-packages/roombapy/roomba_factory.py”, line 14, in create_roomba
remote_client = RoombaFactory._create_remote_client(
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/local/lib/python3.12/site-packages/roombapy/roomba_factory.py”, line 21, in _create_remote_client
return RoombaRemoteClient(address=address, blid=blid, password=password)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/local/lib/python3.12/site-packages/roombapy/remote_client.py”, line 44, in init
self.mqtt_client = self._get_mqtt_client()
^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/local/lib/python3.12/site-packages/roombapy/remote_client.py”, line 103, in _get_mqtt_client
callback_api_version=mqtt.CallbackAPIVersion.VERSION1,
^^^^^^^^^^^^^^^^^^^^^^^
AttributeError: module ‘paho.mqtt.client’ has no attribute ‘CallbackAPIVersion’
2024-02-25 17:45:45.381 ERROR (MainThread) [homeassistant.config_entries] Error setting up entry Robert for roomba
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/config_entries.py”, line 444, in async_setup
result = await component.async_setup_entry(hass, self)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/src/homeassistant/homeassistant/components/roomba/init.py”, line 40, in async_setup_entry
roomba = await hass.async_add_executor_job(
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/local/lib/python3.12/concurrent/futures/thread.py”, line 58, in run
result = self.fn(*self.args, **self.kwargs)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/local/lib/python3.12/site-packages/roombapy/roomba_factory.py”, line 14, in create_roomba
remote_client = RoombaFactory._create_remote_client(
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/local/lib/python3.12/site-packages/roombapy/roomba_factory.py”, line 21, in _create_remote_client
return RoombaRemoteClient(address=address, blid=blid, password=password)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/local/lib/python3.12/site-packages/roombapy/remote_client.py”, line 44, in init
self.mqtt_client = self._get_mqtt_client()
^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/local/lib/python3.12/site-packages/roombapy/remote_client.py”, line 103, in _get_mqtt_client
callback_api_version=mqtt.CallbackAPIVersion.VERSION1,
^^^^^^^^^^^^^^^^^^^^^^^
AttributeError: module ‘paho.mqtt.client’ has no attribute ‘CallbackAPIVersion’

2 Likes

Hi,

This is a known problem. We will have to wait for the 2024.3 update for a fix. :worried:

1 Like

2024.2.3 broke something else … wait again.

2 Likes

Same problem is also reported by integration with iRobot fails to start - 'paho.mqtt.client' has no attribute 'CallbackAPIVersion' · Issue #111473 · home-assistant/core · GitHub

Latest Update to HA Core 2024.2.4 solved the issue

1 Like

Same here. Still is not fixed in 2024.2.4.
These kind of bugs are really annoying.

What exactly wasn’t fixed?

Tried to upgrade to 2024.2.4,still shows that integration failed (Same as upgrading to 2024.2.3) . As soon as I downgraded back to 2024.2.2, integration showed OK (turned to be green again).I will try to preform upgrade once more.

Please, remove robots from HA, enable debug logging for library and integration:

logger:
  default: info
  logs:
    homeassistant.components.roomba: debug
    roombapy: debug

Then restart HA and try to add robot. If it fails, post logs, I’ll take a look.

mine (combo j7) is working after the 2024.2.4 update. However it does not show up in the custom vacuum card. Works fine as a regular entity. Strange.

Track Roomba Combo vacuum cleaner is found but the Status attribute is no longer availableand the Lovelace custom card is blank · Issue #111639 · home-assistant/core · GitHub for details

1 Like

I have it the other way round. Since two weeks, I cannot use the iRobot App anymore to command the Roomba (i7) - if and only if - the integration is active.

I can press buttons in the App, nothing is happening. If I disable the integration, the commands are working directly.

Only for the Roomba. The Braava does not have the problem.

Continuously and 60s in the settings. But this was the case before as well and I never faced any problems with that. And is working with the Braava as well.

Any ideas?

I’m struggling to add a J9 to this integration (was replacing a I7 that was already working in addition to a Braava that was working great too). I’m on 2024.3.

Reproducible behavior:

  • launch integration via “ADD ENTRY”
  • doesn’t autodiscover, but nbd
  • asks for IP addr / host name (I can confirm the new robot is on the network – ironically my router’s HA integration sees the device on the network)
  • HA returns with “Retrieve Password” – which I supply (used Get-Roomba-Password-Cloud via dorita980)
  • hold button on robot down for about 10 secs (until chime), then hit enter on the IP address (also tried quick press on button, jic)
  • Exits with “Failed to Connect”

I have made sure not other connections to the iRobot cloud were active. I’ve rebooted the iRobot and my router, all to no avail. I’ve also upgraded and downgraded my HA core firmware. I’ve combed the community but cannot figure this out. Appreciate any suggestions.

Thanks in advance.

EDIT: here is the accompanying log: