Is it possible to run ebusd in a supervised HA installation?

Tags: #<Tag:0x00007f326e0b1d58>

Hello, I am new to HA and my question is - how to run ebusd (a third party utility protocol daemon) on the same host with HA supervised installation? So that the built-in ebusd integration would talk to the said daemon on the same machine.

I guess Docker could be an answer, according to https://hub.docker.com/r/john30/ebusd/. What I miss is understanding of how to set the whole thing up. Any help is greatly appreciated.

Regards
Tim

1 Like

Hi, I’m struggling with the same thing. Have you been able to run ebusd on you HA ?

Looks like I have some progress. Even if you already managed to do this I’ll leave my version here in case someone else having the same issue.

The first thing I installed is Portainer in order to run the docker container. Then I tried to run you mentioned. But the problem is that it is set up for amd64. Raspberry Pi is arm architecture. Fortunately enough hub.docker.com has a filter by the architecture and someone already forced ebusd image and adopted it for arm… I’ve used this one https://hub.docker.com/r/lukics/ebusd-3.3.

I the Portainer chose images section choose DockerHub for registry and type lukics/ebusd:armv7 for Image and click Pull the image. Than in the container section click Add container. Name somehow. ebusd for instance. Type lukics/ebusd:armv7 in Image field. Then click publish a new network port next to Manual network port publishing. Type 8888 for both host and container.
In the Advanced container settings select Interactive & TTY (-i -t).
In Restart policy choose Always.
In Runtime & Resources click add device next to devices. Type /dev/ttyUSB0 for both host and container. (actually for host it may vary depending on which port your adapter is plugged. But for me it worked with USB0).
Now you can hit Deply the container button and see the logs if it works properly. You should be able to see the ebusd outpul in logs an run ebusctl commands in the console.

Next if container works well you need to add fe lines to your /config/configuration.yaml file.
Here are some docs. And here is my setup:

ebusd:
  host: 127.0.0.1
  circuit: 'bai'
  port: 8888
  name: 'Vaillant'
  monitored_conditions: ['HotWaterTemperature', 'StorageTemperature', 'DesiredStorageTemperature', 'OutdoorsTemperature', 'WaterPreasure', 'ReturnTemperature', 'DesiredFlowTemperature', 'FlowTemperature', 'Flame']

Probably now you need to reboot your home assistant. And you will be able to use these sensors.

1 Like

Hi Oleg, thanks for great guide! Will give it a try.

I have installed Portainer, had to turn off Protection mode (otherwise it would not start). Now I am stuck at the Registries view:

Could you please show how your Registries page looks like?

hm. now I have the same issue. Either portainer was updated or my trial period expired… I’ve never been working with portainer before…

Upd: it is strange that left side menu does not contain quite a lot of options when i open it on my phone (despite checking descrop mode) but on pc it contains everything…

Well I managed to install Portainer at last. Still get an error “Unable to pull image” when trying to Download “lukics/ebusd-3.3:armv7” from docker.io :frowning: