Is there anyone running a HifiBerry DAC on a Raspberry Pi HA setup?

I’m trying to use my HifiBerry DAC+ on a raspberry pi 3b Home Assistant setup (OS 8.5) and I can’t get the DAC to show up as an output no matter what I do. About a year ago I was running this exact same setup but with an older OS version (I think it was 6) and everything worked fine. I then loaded a Volumio image onto a spare sd card to see if maybe the DAC was dead, but it shows up just fine and everything works, which makes me think something must have changed in the Home Assistant OS in the subsequent updates to cause this issue. Is there anyone out there that has a working (and up-to-date) HifiBerry DAC setup that could share what they did to get it running? I would really appreciate some help!

I’m also at your situation. I have a Raspberry Pi 3 running Home Assistant OS (details below). I also have hifiberry-digi-pro and I want to attach it to the same Raspberry Pi and play audio. Is there any way to do that?

Home Assistant 2022.9.0
Supervisor 2022.08.6
Operating System 8.5
Frontend 20220907.0 - latest

Hi, i was also just looking for a solution for this, with the difference of having a pcm5102 module instead of a HAT.

I’m as far as having installed the HA-RPI GPIO integration, which was removed from the HA Core in version 2022.6.

Have you come any further?

OK, got it running:

I put the SD-Card into my laptop, mounted the hassos-boot partition (the first partition, it wasn’t automatically mounted in my case) and followed the boot/config.txt part of this guide:

Open config.txt
Uncomment (remove the # before) dtparam=i2s=on
Comment #dtparam=audio=on
Append this at the end of the file: dtoverlay=hifiberry-dac

Incidentally the pcm5102 is even the same DAC as in the hifiberry-dac.

And it works :slight_smile: The device is shown as internal audio device in HA, but that’s ok for me.

Great news! I randomly decided to attach my hifiberry to my raspberry pi running Home Assistant again after tinkering with the rest of my audio setup and it now works perfectly!? I had some standoffs supporting the hifiberry above the pi originally, but I had misplaced them somewhere and decided to just plug it in without them. Lo-and-behold, the hifiberry appeared as an “internal audio device” same as you @orangescentedmelon and spotify connect sends sound to it just fine!

I’m not really sure what happened, but if anyone runs into the same issue, try placing the hifiberry board so the header goes all the way in.

Edit: I also didn’t do anything configuration-wise besides the default steps recommended by hifiberry here: https://www.hifiberry.com/docs/software/configuring-linux-3-18-x/

Which HA install are you using? The supervisor version does not allow me access to the boot file so i was not able to add the dtoverlay = hifiberry-digi line in config.txt.
Probably you have HA installed in the raspbian os?

I guess in that case you can manually configurate the alsa sound sink to hifiberry.

I’m running the Home Assistant OS installed on an SSD attached to a raspberry pi 3b. I haven’t tried using a supervised install, but you should be able to access the config.txt file on any type of install though right? Have you looked here? Look under configuring access to files

Hi,
yes i did try that but you end up at the /config directory which is also accessible via the Studio Code addon.
The ALSA settings are in /boot and that cannot be reached by me.